PHP-FFMpeg

PHP-FFMpeg

Member Since 8 years ago

Experience Points
0
follower
Lessons Completed
0
follow
Best Reply Awards
3
repos
Activity
Jan
24
7 hours ago
started
started time in 5 hours ago
Jan
23
1 day ago
started
started time in 17 hours ago
Jan
22
2 days ago
started
started time in 2 days ago
Jan
21
3 days ago
started
started time in 2 days ago
started
started time in 3 days ago
Jan
18
6 days ago
started
started time in 5 days ago
started
started time in 5 days ago
started
started time in 5 days ago
Jan
17
1 week ago
Activity icon
issue

pascalbaljet issue comment PHP-FFMpeg/PHP-FFMpeg

pascalbaljet
pascalbaljet

Cannot install on php8.1 and symfony6

| Version | not installed yet php 8.1 symfony 6

Support Question

cannot install php-ffmpeg/php-ffmpeg

is it totally incompatible with my configuration ?

error message:

Your requirements could not be resolved to an installable set of packages.
 
   Problem 1
     - php-ffmpeg/php-ffmpeg[0.3.0, ..., 0.6.0] require alchemy/binary-driver ~1.5 -> satisfiable by alchemy/binary-driver[1.5.0, 1.6.0].
     - php-ffmpeg/php-ffmpeg[v0.17.0, ..., v0.18.0] require alchemy/binary-driver ^1.5 || ~2.0.0 || ^5.0 -> satisfiable by alchemy/binary-driver[1.5.0, 1.6.0, v2.0.0, 5.0.0, 5.1.0, v5.1.1, v5.2.0].
     - php-ffmpeg/php-ffmpeg[0.1.0, ..., 0.2.1] require symfony/process >=2.0,<=2.2 -> found symfony/process[2.0.4, ..., v2.2.0] but these were not loaded, likely because it conflicts with another require.
     - php-ffmpeg/php-ffmpeg[0.2.2, ..., 0.2.4] require symfony/process ~2.0 -> found symfony/process[2.0.4, ..., v2.8.52] but these were not loaded, likely because it conflicts with another require.
     - alchemy/binary-driver 1.5.0 require symfony/process ~2.0 -> found symfony/process[2.0.4, ..., v2.8.52] but these were not loaded, likely because it conflicts with another require.
     - php-ffmpeg/php-ffmpeg[0.6.1, ..., v0.16] require php ^5.3.9 || ^7.0 -> your php version (8.1.0) does not satisfy that requirement.
     - alchemy/binary-driver 1.6.0 requires symfony/process ^2.0|^3.0 -> found symfony/process[2.0.4, ..., v2.8.52, v3.0.0, ..., v3.4.47] but these were not loaded, likely because it conflicts with another require.
     - alchemy/binary-driver[v2.0.0, 5.0.0, ..., v5.1.1] require symfony/process ^2.3|^3.0|^4.0 -> found symfony/process[v2.3.0, ..., v2.8.52, v3.0.0, ..., v3.4.47, v4.0.0, ..., v4.4.35] but these were not loaded, likely because it conflicts with another require.
     - alchemy/binary-driver v5.2.0 requires symfony/process ^2.3|^3.0|^4.0|^5.0 -> found symfony/process[v2.3.0, ..., v2.8.52, v3.0.0, ..., v3.4.47, v4.0.0, ..., v4.4.35, v5.0.0, ..., v5.4.0] but these were not loaded, likely because it conflicts with another require.
     - Root composer.json requires php-ffmpeg/php-ffmpeg * -> satisfiable by php-ffmpeg/php-ffmpeg[0.1.0, ..., v0.18.0].

my composer.json

{
    "type": "project",
    "license": "proprietary",
    "minimum-stability": "stable",
    "prefer-stable": true,
    "require": {
        "php": ">=8.1.0",
        "ext-ctype": "*",
        "ext-fileinfo": "*",
        "ext-gd": "*",
        "ext-iconv": "*",
        "ext-imagick": "^3.6",
        "ext-json": "*",
        "ext-openssl": "*",
        "doctrine/doctrine-bundle": "^2.5",
        "doctrine/orm": "^2.10",
        "jms/serializer-bundle": "^4.0",
        "knplabs/knp-paginator-bundle": "^5.8",
        "symfony/asset": "6.0.*",
        "symfony/cache": "6.0.*",
        "symfony/config": "6.0.*",
        "symfony/console": "6.0.*",
        "symfony/dependency-injection": "6.0.*",
        "symfony/dotenv": "6.0.*",
        "symfony/flex": "^2",
        "symfony/framework-bundle": "6.0.*",
        "symfony/mailer": "6.0.*",
        "symfony/mime": "6.0.*",
        "symfony/runtime": "6.0.*",
        "symfony/twig-bundle": "6.0.*",
        "symfony/validator": "6.0.*",
        "symfony/web-profiler-bundle": "6.0.*",
        "symfony/yaml": "6.0.*"
        "php-ffmpeg/php-ffmpeg": "*"
    },
    "require-dev": {
        "symfony/maker-bundle": "^1.36",
        "symfony/var-dumper": "6.0.*"
    },
    "config": {
        "optimize-autoloader": true,
        "preferred-install": {
            "*": "dist"
        },
        "sort-packages": true
    },
    "autoload": {
        "psr-4": {
            "App\\": "src/"
        }
    },
    "autoload-dev": {
        "psr-4": {
            "App\\Tests\\": "tests/"
        }
    },
    "replace": {
        "symfony/polyfill-ctype": "*",
        "symfony/polyfill-iconv": "*",
        "symfony/polyfill-php72": "*",
        "symfony/polyfill-php73": "*",
        "symfony/polyfill-php74": "*",
        "symfony/polyfill-php80": "*"
    },
    "scripts": {
        "auto-scripts": {
            "cache:clear": "symfony-cmd",
            "assets:install %PUBLIC_DIR%": "symfony-cmd"
        },
        "post-install-cmd": [
            "@auto-scripts"
        ],
        "post-update-cmd": [
            "@auto-scripts"
        ]
    },
    "conflict": {
        "symfony/symfony": "*"
    },
    "extra": {
        "symfony": {
            "allow-contrib": false,
            "require": "6.0.*"
        }
    }
}

pascalbaljet
pascalbaljet

A few weeks before I became a maintainer of this repo, I started working on a modernized fork: https://github.com/protonemedia/php-ffmpeg/

The packages alchemy/binary-driver, evenement/evenement, and neutron/temporary-filesystem are removed or adapted, and there's only support for PHP 8.0 and higher.

There are probably some breaking changes, but I'd love to merge the modernized fork into this repo.

Activity icon
issue

secit-pl issue comment PHP-FFMpeg/PHP-FFMpeg

secit-pl
secit-pl

Cannot install on php8.1 and symfony6

| Version | not installed yet php 8.1 symfony 6

Support Question

cannot install php-ffmpeg/php-ffmpeg

is it totally incompatible with my configuration ?

error message:

Your requirements could not be resolved to an installable set of packages.
 
   Problem 1
     - php-ffmpeg/php-ffmpeg[0.3.0, ..., 0.6.0] require alchemy/binary-driver ~1.5 -> satisfiable by alchemy/binary-driver[1.5.0, 1.6.0].
     - php-ffmpeg/php-ffmpeg[v0.17.0, ..., v0.18.0] require alchemy/binary-driver ^1.5 || ~2.0.0 || ^5.0 -> satisfiable by alchemy/binary-driver[1.5.0, 1.6.0, v2.0.0, 5.0.0, 5.1.0, v5.1.1, v5.2.0].
     - php-ffmpeg/php-ffmpeg[0.1.0, ..., 0.2.1] require symfony/process >=2.0,<=2.2 -> found symfony/process[2.0.4, ..., v2.2.0] but these were not loaded, likely because it conflicts with another require.
     - php-ffmpeg/php-ffmpeg[0.2.2, ..., 0.2.4] require symfony/process ~2.0 -> found symfony/process[2.0.4, ..., v2.8.52] but these were not loaded, likely because it conflicts with another require.
     - alchemy/binary-driver 1.5.0 require symfony/process ~2.0 -> found symfony/process[2.0.4, ..., v2.8.52] but these were not loaded, likely because it conflicts with another require.
     - php-ffmpeg/php-ffmpeg[0.6.1, ..., v0.16] require php ^5.3.9 || ^7.0 -> your php version (8.1.0) does not satisfy that requirement.
     - alchemy/binary-driver 1.6.0 requires symfony/process ^2.0|^3.0 -> found symfony/process[2.0.4, ..., v2.8.52, v3.0.0, ..., v3.4.47] but these were not loaded, likely because it conflicts with another require.
     - alchemy/binary-driver[v2.0.0, 5.0.0, ..., v5.1.1] require symfony/process ^2.3|^3.0|^4.0 -> found symfony/process[v2.3.0, ..., v2.8.52, v3.0.0, ..., v3.4.47, v4.0.0, ..., v4.4.35] but these were not loaded, likely because it conflicts with another require.
     - alchemy/binary-driver v5.2.0 requires symfony/process ^2.3|^3.0|^4.0|^5.0 -> found symfony/process[v2.3.0, ..., v2.8.52, v3.0.0, ..., v3.4.47, v4.0.0, ..., v4.4.35, v5.0.0, ..., v5.4.0] but these were not loaded, likely because it conflicts with another require.
     - Root composer.json requires php-ffmpeg/php-ffmpeg * -> satisfiable by php-ffmpeg/php-ffmpeg[0.1.0, ..., v0.18.0].

my composer.json

{
    "type": "project",
    "license": "proprietary",
    "minimum-stability": "stable",
    "prefer-stable": true,
    "require": {
        "php": ">=8.1.0",
        "ext-ctype": "*",
        "ext-fileinfo": "*",
        "ext-gd": "*",
        "ext-iconv": "*",
        "ext-imagick": "^3.6",
        "ext-json": "*",
        "ext-openssl": "*",
        "doctrine/doctrine-bundle": "^2.5",
        "doctrine/orm": "^2.10",
        "jms/serializer-bundle": "^4.0",
        "knplabs/knp-paginator-bundle": "^5.8",
        "symfony/asset": "6.0.*",
        "symfony/cache": "6.0.*",
        "symfony/config": "6.0.*",
        "symfony/console": "6.0.*",
        "symfony/dependency-injection": "6.0.*",
        "symfony/dotenv": "6.0.*",
        "symfony/flex": "^2",
        "symfony/framework-bundle": "6.0.*",
        "symfony/mailer": "6.0.*",
        "symfony/mime": "6.0.*",
        "symfony/runtime": "6.0.*",
        "symfony/twig-bundle": "6.0.*",
        "symfony/validator": "6.0.*",
        "symfony/web-profiler-bundle": "6.0.*",
        "symfony/yaml": "6.0.*"
        "php-ffmpeg/php-ffmpeg": "*"
    },
    "require-dev": {
        "symfony/maker-bundle": "^1.36",
        "symfony/var-dumper": "6.0.*"
    },
    "config": {
        "optimize-autoloader": true,
        "preferred-install": {
            "*": "dist"
        },
        "sort-packages": true
    },
    "autoload": {
        "psr-4": {
            "App\\": "src/"
        }
    },
    "autoload-dev": {
        "psr-4": {
            "App\\Tests\\": "tests/"
        }
    },
    "replace": {
        "symfony/polyfill-ctype": "*",
        "symfony/polyfill-iconv": "*",
        "symfony/polyfill-php72": "*",
        "symfony/polyfill-php73": "*",
        "symfony/polyfill-php74": "*",
        "symfony/polyfill-php80": "*"
    },
    "scripts": {
        "auto-scripts": {
            "cache:clear": "symfony-cmd",
            "assets:install %PUBLIC_DIR%": "symfony-cmd"
        },
        "post-install-cmd": [
            "@auto-scripts"
        ],
        "post-update-cmd": [
            "@auto-scripts"
        ]
    },
    "conflict": {
        "symfony/symfony": "*"
    },
    "extra": {
        "symfony": {
            "allow-contrib": false,
            "require": "6.0.*"
        }
    }
}

secit-pl
secit-pl

Could the alchemy-fr/BinaryDriver be replaced with symfony/process?

started
started time in 6 days ago
Jan
16
1 week ago
started
started time in 1 week ago
Jan
14
1 week ago
started
started time in 1 week ago
Activity icon
fork

syed-MTalha forked PHP-FFMpeg/PHP-FFMpeg

⚡ An object oriented PHP driver for FFMpeg binary
syed-MTalha Updated
fork time in 1 week ago
started
started time in 1 week ago
Jan
13
1 week ago
started
started time in 1 week ago
Activity icon
issue

yesworld issue PHP-FFMpeg/PHP-FFMpeg

yesworld
yesworld

[Question] Protocol Options -protocol_whitelist

Hi there,

How can I pass parameters to the protocol_whitelist? '-protocol_whitelist', 'file,http,https,tcp,tls',

https://github.com/PHP-FFMpeg/PHP-FFMpeg/blob/72c946dc7d18b0e6ce5e2edcf02afe6e9f3f0dcb/src/FFMpeg/Media/Concat.php#L122

I need it to be like this

 $commands = array(
            '-f', 'concat', '-safe', '0',
            '-protocol_whitelist', 'file,http,https,tcp,tls',
            '-i', $sourcesFile,
        );

Thanks.

started
started time in 1 week ago
Jan
11
1 week ago
Activity icon
issue

MrMuminov issue comment PHP-FFMpeg/PHP-FFMpeg

MrMuminov
MrMuminov

Can I use this tool to normalize audio files?

Q A
Bug? no
New Feature? maybe
Version Used I don't know how to find out
FFmpeg Version git-2017-01-22-f1214ad
OS Ubuntu 14.04.5 x64

Hi. I've using this tool for file conversions but I wonder if it can be used to normalize audio files to a specific volume level like ## db.

BTW Thanks for your amazing job.

MrMuminov
MrMuminov

no, it's not possible to do that, yet. But it's a great idea. I'm making a pr.

Is there a result?

started
started time in 1 week ago
Activity icon
fork

muhiteng forked PHP-FFMpeg/PHP-FFMpeg

⚡ An object oriented PHP driver for FFMpeg binary
muhiteng Updated
fork time in 1 week ago
started
started time in 1 week ago
started
started time in 1 week ago
Jan
10
2 weeks ago
started
started time in 2 weeks ago
Jan
8
2 weeks ago
started
started time in 2 weeks ago
Jan
7
2 weeks ago
started
started time in 2 weeks ago
Activity icon
fork

mathpro12 forked PHP-FFMpeg/PHP-FFMpeg

⚡ An object oriented PHP driver for FFMpeg binary
mathpro12 Updated
fork time in 2 weeks ago
Jan
6
2 weeks ago
Activity icon
issue

azurre issue comment PHP-FFMpeg/PHP-FFMpeg

azurre
azurre

Cannot install on php8.1 and symfony6

| Version | not installed yet php 8.1 symfony 6

Support Question

cannot install php-ffmpeg/php-ffmpeg

is it totally incompatible with my configuration ?

error message:

Your requirements could not be resolved to an installable set of packages.
 
   Problem 1
     - php-ffmpeg/php-ffmpeg[0.3.0, ..., 0.6.0] require alchemy/binary-driver ~1.5 -> satisfiable by alchemy/binary-driver[1.5.0, 1.6.0].
     - php-ffmpeg/php-ffmpeg[v0.17.0, ..., v0.18.0] require alchemy/binary-driver ^1.5 || ~2.0.0 || ^5.0 -> satisfiable by alchemy/binary-driver[1.5.0, 1.6.0, v2.0.0, 5.0.0, 5.1.0, v5.1.1, v5.2.0].
     - php-ffmpeg/php-ffmpeg[0.1.0, ..., 0.2.1] require symfony/process >=2.0,<=2.2 -> found symfony/process[2.0.4, ..., v2.2.0] but these were not loaded, likely because it conflicts with another require.
     - php-ffmpeg/php-ffmpeg[0.2.2, ..., 0.2.4] require symfony/process ~2.0 -> found symfony/process[2.0.4, ..., v2.8.52] but these were not loaded, likely because it conflicts with another require.
     - alchemy/binary-driver 1.5.0 require symfony/process ~2.0 -> found symfony/process[2.0.4, ..., v2.8.52] but these were not loaded, likely because it conflicts with another require.
     - php-ffmpeg/php-ffmpeg[0.6.1, ..., v0.16] require php ^5.3.9 || ^7.0 -> your php version (8.1.0) does not satisfy that requirement.
     - alchemy/binary-driver 1.6.0 requires symfony/process ^2.0|^3.0 -> found symfony/process[2.0.4, ..., v2.8.52, v3.0.0, ..., v3.4.47] but these were not loaded, likely because it conflicts with another require.
     - alchemy/binary-driver[v2.0.0, 5.0.0, ..., v5.1.1] require symfony/process ^2.3|^3.0|^4.0 -> found symfony/process[v2.3.0, ..., v2.8.52, v3.0.0, ..., v3.4.47, v4.0.0, ..., v4.4.35] but these were not loaded, likely because it conflicts with another require.
     - alchemy/binary-driver v5.2.0 requires symfony/process ^2.3|^3.0|^4.0|^5.0 -> found symfony/process[v2.3.0, ..., v2.8.52, v3.0.0, ..., v3.4.47, v4.0.0, ..., v4.4.35, v5.0.0, ..., v5.4.0] but these were not loaded, likely because it conflicts with another require.
     - Root composer.json requires php-ffmpeg/php-ffmpeg * -> satisfiable by php-ffmpeg/php-ffmpeg[0.1.0, ..., v0.18.0].

my composer.json

{
    "type": "project",
    "license": "proprietary",
    "minimum-stability": "stable",
    "prefer-stable": true,
    "require": {
        "php": ">=8.1.0",
        "ext-ctype": "*",
        "ext-fileinfo": "*",
        "ext-gd": "*",
        "ext-iconv": "*",
        "ext-imagick": "^3.6",
        "ext-json": "*",
        "ext-openssl": "*",
        "doctrine/doctrine-bundle": "^2.5",
        "doctrine/orm": "^2.10",
        "jms/serializer-bundle": "^4.0",
        "knplabs/knp-paginator-bundle": "^5.8",
        "symfony/asset": "6.0.*",
        "symfony/cache": "6.0.*",
        "symfony/config": "6.0.*",
        "symfony/console": "6.0.*",
        "symfony/dependency-injection": "6.0.*",
        "symfony/dotenv": "6.0.*",
        "symfony/flex": "^2",
        "symfony/framework-bundle": "6.0.*",
        "symfony/mailer": "6.0.*",
        "symfony/mime": "6.0.*",
        "symfony/runtime": "6.0.*",
        "symfony/twig-bundle": "6.0.*",
        "symfony/validator": "6.0.*",
        "symfony/web-profiler-bundle": "6.0.*",
        "symfony/yaml": "6.0.*"
        "php-ffmpeg/php-ffmpeg": "*"
    },
    "require-dev": {
        "symfony/maker-bundle": "^1.36",
        "symfony/var-dumper": "6.0.*"
    },
    "config": {
        "optimize-autoloader": true,
        "preferred-install": {
            "*": "dist"
        },
        "sort-packages": true
    },
    "autoload": {
        "psr-4": {
            "App\\": "src/"
        }
    },
    "autoload-dev": {
        "psr-4": {
            "App\\Tests\\": "tests/"
        }
    },
    "replace": {
        "symfony/polyfill-ctype": "*",
        "symfony/polyfill-iconv": "*",
        "symfony/polyfill-php72": "*",
        "symfony/polyfill-php73": "*",
        "symfony/polyfill-php74": "*",
        "symfony/polyfill-php80": "*"
    },
    "scripts": {
        "auto-scripts": {
            "cache:clear": "symfony-cmd",
            "assets:install %PUBLIC_DIR%": "symfony-cmd"
        },
        "post-install-cmd": [
            "@auto-scripts"
        ],
        "post-update-cmd": [
            "@auto-scripts"
        ]
    },
    "conflict": {
        "symfony/symfony": "*"
    },
    "extra": {
        "symfony": {
            "allow-contrib": false,
            "require": "6.0.*"
        }
    }
}

azurre
azurre

@pascalbaljet It looks like alchemy-fr/BinaryDriver is dead. Last change was 2 years ago.

started
started time in 2 weeks ago
Previous