Rc85

Rc85

Member Since 5 years ago

Experience Points
1
follower
Lessons Completed
0
follow
Best Reply Awards
7
repos

45 contributions in the last year

Pinned
Activity
Jan
21
1 day ago
Activity icon
issue

Rc85 issue facebook/react-native

Rc85
Rc85

Could not find com.facebook.fresco.stetho

Description

* What went wrong:
Execution failed for task ':app:mergeDebugAssets'.
> Could not resolve all files for configuration ':app:debugRuntimeClasspath'.
   > Could not find com.facebook.fresco:stetho:2.2.0.
     Searched in the following locations:
       - file:/C:/Users/roger/.m2/repository/com/facebook/fresco/stetho/2.2.0/stetho-2.2.0.pom
       - file:/F:/Projects/my_takeouts/client/mobile/marketplace/node_modules/react-native/android/com/facebook/fresco/stetho/2.2.0/stetho-2.2.0.pom
       - file:/F:/Projects/my_takeouts/client/mobile/marketplace/node_modules/jsc-android/dist/com/facebook/fresco/stetho/2.2.0/stetho-2.2.0.pom
       - https://dl.google.com/dl/android/maven2/com/facebook/fresco/stetho/2.2.0/stetho-2.2.0.pom
       - https://repo.maven.apache.org/maven2/com/facebook/fresco/stetho/2.2.0/stetho-2.2.0.pom
       - https://www.jitpack.io/com/facebook/fresco/stetho/2.2.0/stetho-2.2.0.pom
     Required by:
         project :app > com.facebook.flipper:flipper-fresco-plugin:0.75.1

This only happens when I use mavenCentral in android/build.gradle. Using jcenter is fine. But jcenter is gonna be removed soon.

https://github.com/facebook/flipper/issues/2410

Version

0.66.4

Output of npx react-native info

System:
    OS: Windows 10 10.0.19042
    CPU: (16) x64 AMD Ryzen 7 2700X Eight-Core Processor
    Memory: 10.96 GB / 31.93 GB
  Binaries:
    Node: 14.16.0 - C:\Program Files\nodejs\node.EXE
    Yarn: 1.22.10 - ~\AppData\Roaming\npm\yarn.CMD
    npm: 6.14.11 - C:\Program Files\nodejs\npm.CMD
    Watchman: Not Found
  SDKs:
    Android SDK: Not Found
    Windows SDK: Not Found
  IDEs:
    Android Studio: Version  4.1.0.0 AI-201.8743.12.41.7042882
    Visual Studio: 15.9.28307.1401 (Visual Studio Community 2017)
  Languages:
    Java: 17.0.1
  npmPackages:
    @react-native-community/cli: Not Found
    react: ^17.0.2 => 17.0.2
    react-native: ^0.66.4 => 0.66.4
    react-native-windows: Not Found
  npmGlobalPackages:
    *react-native*: Not Found

Steps to reproduce

  1. Use mavenCentral in android/build.gradle
  2. Run app in development

Snack, code example, screenshot, or link to a repository

android/build.gradle

// Top-level build file where you can add configuration options common to all sub-projects/modules.

buildscript {
    ext {
        minSdkVersion = 23
        compileSdkVersion = 31
        targetSdkVersion = 31
        ndkVersion = "20.1.5948944"
        googlePlayServicesVersion = "17.0.0"
        kotlinVersion = "1.5.20"
    }
    repositories {
        google()
        mavenCentral()
    }
    dependencies {
        classpath("com.android.tools.build:gradle:7.0.0")
        classpath 'com.google.gms:google-services:4.3.8'
        classpath "org.jetbrains.kotlin:kotlin-gradle-plugin:$kotlinVersion"
        // NOTE: Do not place your application dependencies here; they belong
        // in the individual module build.gradle files
    }
}

allprojects {
    repositories {
        mavenLocal()
        maven {
            // All of React Native (JS, Obj-C sources, Android binaries) is installed from npm
            url("$rootDir/../node_modules/react-native/android")
        }
        maven {
            // Android JSC is installed from npm
            url("$rootDir/../node_modules/jsc-android/dist")
        }

        google()
        mavenCentral()
        maven { url 'https://www.jitpack.io' }
    }
}

android/app.build.gradle (omitted some code)

dependencies {
    implementation fileTree(dir: "libs", include: ["*.jar"])
    //noinspection GradleDynamicVersion
    implementation "com.facebook.react:react-native:+"  // From node_modules

    implementation "androidx.core:core-splashscreen:1.0.0-alpha02"
    implementation "androidx.swiperefreshlayout:swiperefreshlayout:1.0.0"

    debugImplementation("com.facebook.flipper:flipper:${FLIPPER_VERSION}") {
      exclude group:'com.facebook.fbjni'
    }

    debugImplementation("com.facebook.flipper:flipper-network-plugin:${FLIPPER_VERSION}") {
        exclude group:'com.facebook.flipper'
        exclude group:'com.squareup.okhttp3', module:'okhttp'
    }

    debugImplementation("com.facebook.flipper:flipper-fresco-plugin:${FLIPPER_VERSION}") {
        exclude group:'com.facebook.flipper'
    }

    if (enableHermes) {
        def hermesPath = "../../node_modules/hermes-engine/android/";
        debugImplementation files(hermesPath + "hermes-debug.aar")
        releaseImplementation files(hermesPath + "hermes-release.aar")
    } else {
        implementation jscFlavor
    }

    implementation platform('com.google.firebase:firebase-bom:28.2.1')
    implementation 'com.facebook.android:facebook-android-sdk:[5,6)'
    implementation 'com.facebook.android:facebook-share:[5,6)'
    implementation 'com.android.support:multidex:2.0.1'

    implementation 'com.google.android.gms:play-services-wallet:19.0.1'
}

// Run this once to be able to run the application with BUCK
// puts all compile dependencies into folder libs for BUCK to use
task copyDownloadableDepsToLibs(type: Copy) {
    from configurations.implementation
    into 'libs'
}

apply from: file("../../node_modules/@react-native-community/cli-platform-android/native_modules.gradle"); applyNativeModulesAppBuildGradle(project)
Activity icon
issue

Rc85 issue comment facebook/flipper

Rc85
Rc85

Could not find com.facebook.fresco:flipper:2.4.0.

🐛 Bug Report

yarn run v1.22.10
$ react-native run-android
info Running jetifier to migrate libraries to AndroidX. You can disable it using "--no-jetifier" flag.
Jetifier found 1860 file(s) to forward-jetify. Using 12 workers...
info JS server already running.
info Launching emulator...
info Successfully launched emulator.
info Installing the app...
Starting a Gradle Daemon (subsequent builds will be faster)
Configuration on demand is an incubating feature.

> Configure project :react-native-firebase_analytics
:react-native-firebase_analytics package.json found at /Users/devloops/Desktop/maple/mobile/node_modules/@react-native-firebase/analytics/package.json
:react-native-firebase_app package.json found at /Users/devloops/Desktop/maple/mobile/node_modules/@react-native-firebase/app/package.json
:react-native-firebase_analytics:firebase.bom using default value: 28.0.1
:react-native-firebase_analytics package.json found at /Users/devloops/Desktop/maple/mobile/node_modules/@react-native-firebase/analytics/package.json
:react-native-firebase_analytics:version set from package.json: 12.0.0 (12,0,0 - 12000000)
:react-native-firebase_analytics:android.compileSdk using custom value: 29
:react-native-firebase_analytics:android.targetSdk using custom value: 29
:react-native-firebase_analytics:android.minSdk using custom value: 21
:react-native-firebase_analytics:reactNativeAndroidDir /Users/devloops/Desktop/maple/mobile/node_modules/react-native/android

> Configure project :react-native-firebase_app
:react-native-firebase_app package.json found at /Users/devloops/Desktop/maple/mobile/node_modules/@react-native-firebase/app/package.json
:react-native-firebase_app:firebase.bom using default value: 28.0.1
:react-native-firebase_app:play.play-services-auth using default value: 19.0.0
:react-native-firebase_app package.json found at /Users/devloops/Desktop/maple/mobile/node_modules/@react-native-firebase/app/package.json
:react-native-firebase_app:version set from package.json: 12.0.0 (12,0,0 - 12000000)
:react-native-firebase_app:android.compileSdk using custom value: 29
:react-native-firebase_app:android.targetSdk using custom value: 29
:react-native-firebase_app:android.minSdk using custom value: 21
:react-native-firebase_app:reactNativeAndroidDir /Users/devloops/Desktop/maple/mobile/node_modules/react-native/android

> Configure project :react-native-firebase_crashlytics
:react-native-firebase_crashlytics package.json found at /Users/devloops/Desktop/maple/mobile/node_modules/@react-native-firebase/crashlytics/package.json
:react-native-firebase_app package.json found at /Users/devloops/Desktop/maple/mobile/node_modules/@react-native-firebase/app/package.json
:react-native-firebase_crashlytics:firebase.bom using default value: 28.0.1
:react-native-firebase_crashlytics package.json found at /Users/devloops/Desktop/maple/mobile/node_modules/@react-native-firebase/crashlytics/package.json
:react-native-firebase_crashlytics:version set from package.json: 12.0.0 (12,0,0 - 12000000)
:react-native-firebase_crashlytics:android.compileSdk using custom value: 29
:react-native-firebase_crashlytics:android.targetSdk using custom value: 29
:react-native-firebase_crashlytics:android.minSdk using custom value: 21
:react-native-firebase_crashlytics:reactNativeAndroidDir /Users/devloops/Desktop/maple/mobile/node_modules/react-native/android

> Configure project :react-native-firebase_in-app-messaging
:react-native-firebase_in-app-messaging package.json found at /Users/devloops/Desktop/maple/mobile/node_modules/@react-native-firebase/in-app-messaging/package.json
:react-native-firebase_app package.json found at /Users/devloops/Desktop/maple/mobile/node_modules/@react-native-firebase/app/package.json
:react-native-firebase_in-app-messaging:firebase.bom using default value: 28.0.1
:react-native-firebase_in-app-messaging package.json found at /Users/devloops/Desktop/maple/mobile/node_modules/@react-native-firebase/in-app-messaging/package.json
:react-native-firebase_in-app-messaging:version set from package.json: 12.0.0 (12,0,0 - 12000000)
:react-native-firebase_in-app-messaging:android.compileSdk using custom value: 29
:react-native-firebase_in-app-messaging:android.targetSdk using custom value: 29
:react-native-firebase_in-app-messaging:android.minSdk using custom value: 21
:react-native-firebase_in-app-messaging:reactNativeAndroidDir /Users/devloops/Desktop/maple/mobile/node_modules/react-native/android

> Configure project :react-native-firebase_messaging
:react-native-firebase_messaging package.json found at /Users/devloops/Desktop/maple/mobile/node_modules/@react-native-firebase/messaging/package.json
:react-native-firebase_app package.json found at /Users/devloops/Desktop/maple/mobile/node_modules/@react-native-firebase/app/package.json
:react-native-firebase_messaging:firebase.bom using default value: 28.0.1
:react-native-firebase_messaging package.json found at /Users/devloops/Desktop/maple/mobile/node_modules/@react-native-firebase/messaging/package.json
:react-native-firebase_messaging:version set from package.json: 12.0.0 (12,0,0 - 12000000)
:react-native-firebase_messaging:android.compileSdk using custom value: 29
:react-native-firebase_messaging:android.targetSdk using custom value: 29
:react-native-firebase_messaging:android.minSdk using custom value: 21
:react-native-firebase_messaging:reactNativeAndroidDir /Users/devloops/Desktop/maple/mobile/node_modules/react-native/android

> Configure project :react-native-firebase_perf
:react-native-firebase_perf package.json found at /Users/devloops/Desktop/maple/mobile/node_modules/@react-native-firebase/perf/package.json
:react-native-firebase_app package.json found at /Users/devloops/Desktop/maple/mobile/node_modules/@react-native-firebase/app/package.json
:react-native-firebase_perf:firebase.bom using default value: 28.0.1
:react-native-firebase_perf package.json found at /Users/devloops/Desktop/maple/mobile/node_modules/@react-native-firebase/perf/package.json
:react-native-firebase_perf:version set from package.json: 12.0.0 (12,0,0 - 12000000)
:react-native-firebase_perf:android.compileSdk using custom value: 29
:react-native-firebase_perf:android.targetSdk using custom value: 29
:react-native-firebase_perf:android.minSdk using custom value: 21
:react-native-firebase_perf:reactNativeAndroidDir /Users/devloops/Desktop/maple/mobile/node_modules/react-native/android

> Configure project :terrylinla_react-native-sketch-canvas
WARNING:: Configuration 'provided' is obsolete and has been replaced with 'compileOnly'.
It will be removed in version 7.0 of the Android Gradle plugin.
For more information, see http://d.android.com/r/tools/update-dependency-configurations.html.

> Configure project :lottie-react-native
WARNING:: The specified Android SDK Build Tools version (29.0.3) is ignored, as it is below the minimum supported version (30.0.2) for Android Gradle Plugin 4.2.1.
Android SDK Build Tools 30.0.2 will be used.
To suppress this warning, remove "buildToolsVersion '29.0.3'" from your build.gradle file, as each version of the Android Gradle Plugin now has a default version of the build tools.

The Kotlin Gradle plugin was loaded multiple times in different subprojects, which is not supported and may break the build. 
This might happen in subprojects that apply the Kotlin plugins with the Gradle 'plugins { ... }' DSL if they specify explicit versions, even if the versions are equal.
Please add the Kotlin plugin to the common parent project or the root project, then remove the versions in the subprojects.
If the parent project does not need the plugin, add 'apply false' to the plugin line.
See: https://docs.gradle.org/current/userguide/plugins.html#sec:subprojects_plugins_dsl
The Kotlin plugin was loaded in the following projects: ':react-native-pager-view', ':react-native-webview'
WARNING:: Please remove usages of `jcenter()` Maven repository from your build scripts and migrate your build to other Maven repositories.
This repository is deprecated and it will be shut down in the future.
See http://developer.android.com/r/tools/jcenter-end-of-service for more information.
Currently detected usages in: project ':react-native-action-sheet', project ':react-native-camera', project ':react-native-community_async-storage', ...

> Task :app:checkDebugAarMetadata FAILED

Deprecated Gradle features were used in this build, making it incompatible with Gradle 7.0.
Use '--warning-mode all' to show the individual deprecation warnings.
See https://docs.gradle.org/6.9/userguide/command_line_interface.html#sec:command_line_warnings
74 actionable tasks: 74 executed

FAILURE: Build failed with an exception.

* What went wrong:
Execution failed for task ':app:checkDebugAarMetadata'.
> Could not resolve all files for configuration ':app:debugRuntimeClasspath'.
   > Could not find com.facebook.fresco:flipper:2.4.0.
     Searched in the following locations:
       - https://repo.maven.apache.org/maven2/com/facebook/fresco/flipper/2.4.0/flipper-2.4.0.pom
       - file:/Users/devloops/.m2/repository/com/facebook/fresco/flipper/2.4.0/flipper-2.4.0.pom
       - file:/Users/devloops/Desktop/maple/mobile/node_modules/react-native/android/com/facebook/fresco/flipper/2.4.0/flipper-2.4.0.pom
       - file:/Users/devloops/Desktop/maple/mobile/node_modules/jsc-android/dist/com/facebook/fresco/flipper/2.4.0/flipper-2.4.0.pom
       - https://dl.google.com/dl/android/maven2/com/facebook/fresco/flipper/2.4.0/flipper-2.4.0.pom
       - https://www.jitpack.io/com/facebook/fresco/flipper/2.4.0/flipper-2.4.0.pom
       - https://maven.google.com/com/facebook/fresco/flipper/2.4.0/flipper-2.4.0.pom
     Required by:
         project :app > com.facebook.flipper:flipper-fresco-plugin:0.92.0
   > Could not find com.facebook.fresco:stetho:2.4.0.
     Searched in the following locations:
       - https://repo.maven.apache.org/maven2/com/facebook/fresco/stetho/2.4.0/stetho-2.4.0.pom
       - file:/Users/devloops/.m2/repository/com/facebook/fresco/stetho/2.4.0/stetho-2.4.0.pom
       - file:/Users/devloops/Desktop/maple/mobile/node_modules/react-native/android/com/facebook/fresco/stetho/2.4.0/stetho-2.4.0.pom
       - file:/Users/devloops/Desktop/maple/mobile/node_modules/jsc-android/dist/com/facebook/fresco/stetho/2.4.0/stetho-2.4.0.pom
       - https://dl.google.com/dl/android/maven2/com/facebook/fresco/stetho/2.4.0/stetho-2.4.0.pom
       - https://www.jitpack.io/com/facebook/fresco/stetho/2.4.0/stetho-2.4.0.pom
       - https://maven.google.com/com/facebook/fresco/stetho/2.4.0/stetho-2.4.0.pom
     Required by:
         project :app > com.facebook.flipper:flipper-fresco-plugin:0.92.0
   > Could not find com.facebook.yoga:proguard-annotations:1.14.1.
     Searched in the following locations:
       - https://repo.maven.apache.org/maven2/com/facebook/yoga/proguard-annotations/1.14.1/proguard-annotations-1.14.1.pom
       - file:/Users/devloops/.m2/repository/com/facebook/yoga/proguard-annotations/1.14.1/proguard-annotations-1.14.1.pom
       - file:/Users/devloops/Desktop/maple/mobile/node_modules/react-native/android/com/facebook/yoga/proguard-annotations/1.14.1/proguard-annotations-1.14.1.pom
       - file:/Users/devloops/Desktop/maple/mobile/node_modules/jsc-android/dist/com/facebook/yoga/proguard-annotations/1.14.1/proguard-annotations-1.14.1.pom
       - https://dl.google.com/dl/android/maven2/com/facebook/yoga/proguard-annotations/1.14.1/proguard-annotations-1.14.1.pom
       - https://www.jitpack.io/com/facebook/yoga/proguard-annotations/1.14.1/proguard-annotations-1.14.1.pom
       - https://maven.google.com/com/facebook/yoga/proguard-annotations/1.14.1/proguard-annotations-1.14.1.pom
     Required by:
         project :app > com.facebook.react:react-native:0.64.1
   > Could not find com.facebook.fbjni:fbjni-java-only:0.0.3.
     Searched in the following locations:
       - https://repo.maven.apache.org/maven2/com/facebook/fbjni/fbjni-java-only/0.0.3/fbjni-java-only-0.0.3.pom
       - file:/Users/devloops/.m2/repository/com/facebook/fbjni/fbjni-java-only/0.0.3/fbjni-java-only-0.0.3.pom
       - file:/Users/devloops/Desktop/maple/mobile/node_modules/react-native/android/com/facebook/fbjni/fbjni-java-only/0.0.3/fbjni-java-only-0.0.3.pom
       - file:/Users/devloops/Desktop/maple/mobile/node_modules/jsc-android/dist/com/facebook/fbjni/fbjni-java-only/0.0.3/fbjni-java-only-0.0.3.pom
       - https://dl.google.com/dl/android/maven2/com/facebook/fbjni/fbjni-java-only/0.0.3/fbjni-java-only-0.0.3.pom
       - https://www.jitpack.io/com/facebook/fbjni/fbjni-java-only/0.0.3/fbjni-java-only-0.0.3.pom
       - https://maven.google.com/com/facebook/fbjni/fbjni-java-only/0.0.3/fbjni-java-only-0.0.3.pom
     Required by:
         project :app > com.facebook.react:react-native:0.64.1
   > Could not find com.yqritc:android-scalablevideoview:1.0.4.
     Searched in the following locations:
       - https://repo.maven.apache.org/maven2/com/yqritc/android-scalablevideoview/1.0.4/android-scalablevideoview-1.0.4.pom
       - file:/Users/devloops/.m2/repository/com/yqritc/android-scalablevideoview/1.0.4/android-scalablevideoview-1.0.4.pom
       - file:/Users/devloops/Desktop/maple/mobile/node_modules/react-native/android/com/yqritc/android-scalablevideoview/1.0.4/android-scalablevideoview-1.0.4.pom
       - file:/Users/devloops/Desktop/maple/mobile/node_modules/jsc-android/dist/com/yqritc/android-scalablevideoview/1.0.4/android-scalablevideoview-1.0.4.pom
       - https://dl.google.com/dl/android/maven2/com/yqritc/android-scalablevideoview/1.0.4/android-scalablevideoview-1.0.4.pom
       - https://www.jitpack.io/com/yqritc/android-scalablevideoview/1.0.4/android-scalablevideoview-1.0.4.pom
       - https://maven.google.com/com/yqritc/android-scalablevideoview/1.0.4/android-scalablevideoview-1.0.4.pom
     Required by:
         project :app > project :react-native-video

* Try:
Run with --stacktrace option to get the stack trace. Run with --info or --debug option to get more log output. Run with --scan to get full insights.

* Get more help at https://help.gradle.org

BUİLD FAILED in 1m 7s

error Failed to install the app. Make sure you have the Android development environment set up: https://reactnative.dev/docs/environment-setup.
Error: Command failed: ./gradlew app:installDebug -PreactNativeDevServerPort=8081

FAILURE: Build failed with an exception.

* What went wrong:
Execution failed for task ':app:checkDebugAarMetadata'.
> Could not resolve all files for configuration ':app:debugRuntimeClasspath'.
   > Could not find com.facebook.fresco:flipper:2.4.0.
     Searched in the following locations:
       - https://repo.maven.apache.org/maven2/com/facebook/fresco/flipper/2.4.0/flipper-2.4.0.pom
       - file:/Users/devloops/.m2/repository/com/facebook/fresco/flipper/2.4.0/flipper-2.4.0.pom
       - file:/Users/devloops/Desktop/maple/mobile/node_modules/react-native/android/com/facebook/fresco/flipper/2.4.0/flipper-2.4.0.pom
       - file:/Users/devloops/Desktop/maple/mobile/node_modules/jsc-android/dist/com/facebook/fresco/flipper/2.4.0/flipper-2.4.0.pom
       - https://dl.google.com/dl/android/maven2/com/facebook/fresco/flipper/2.4.0/flipper-2.4.0.pom
       - https://www.jitpack.io/com/facebook/fresco/flipper/2.4.0/flipper-2.4.0.pom
       - https://maven.google.com/com/facebook/fresco/flipper/2.4.0/flipper-2.4.0.pom
     Required by:
         project :app > com.facebook.flipper:flipper-fresco-plugin:0.92.0
   > Could not find com.facebook.fresco:stetho:2.4.0.
     Searched in the following locations:
       - https://repo.maven.apache.org/maven2/com/facebook/fresco/stetho/2.4.0/stetho-2.4.0.pom
       - file:/Users/devloops/.m2/repository/com/facebook/fresco/stetho/2.4.0/stetho-2.4.0.pom
       - file:/Users/devloops/Desktop/maple/mobile/node_modules/react-native/android/com/facebook/fresco/stetho/2.4.0/stetho-2.4.0.pom
       - file:/Users/devloops/Desktop/maple/mobile/node_modules/jsc-android/dist/com/facebook/fresco/stetho/2.4.0/stetho-2.4.0.pom
       - https://dl.google.com/dl/android/maven2/com/facebook/fresco/stetho/2.4.0/stetho-2.4.0.pom
       - https://www.jitpack.io/com/facebook/fresco/stetho/2.4.0/stetho-2.4.0.pom
       - https://maven.google.com/com/facebook/fresco/stetho/2.4.0/stetho-2.4.0.pom
     Required by:
         project :app > com.facebook.flipper:flipper-fresco-plugin:0.92.0
   > Could not find com.facebook.yoga:proguard-annotations:1.14.1.
     Searched in the following locations:
       - https://repo.maven.apache.org/maven2/com/facebook/yoga/proguard-annotations/1.14.1/proguard-annotations-1.14.1.pom
       - file:/Users/devloops/.m2/repository/com/facebook/yoga/proguard-annotations/1.14.1/proguard-annotations-1.14.1.pom
       - file:/Users/devloops/Desktop/maple/mobile/node_modules/react-native/android/com/facebook/yoga/proguard-annotations/1.14.1/proguard-annotations-1.14.1.pom
       - file:/Users/devloops/Desktop/maple/mobile/node_modules/jsc-android/dist/com/facebook/yoga/proguard-annotations/1.14.1/proguard-annotations-1.14.1.pom
       - https://dl.google.com/dl/android/maven2/com/facebook/yoga/proguard-annotations/1.14.1/proguard-annotations-1.14.1.pom
       - https://www.jitpack.io/com/facebook/yoga/proguard-annotations/1.14.1/proguard-annotations-1.14.1.pom
       - https://maven.google.com/com/facebook/yoga/proguard-annotations/1.14.1/proguard-annotations-1.14.1.pom
     Required by:
         project :app > com.facebook.react:react-native:0.64.1
   > Could not find com.facebook.fbjni:fbjni-java-only:0.0.3.
     Searched in the following locations:
       - https://repo.maven.apache.org/maven2/com/facebook/fbjni/fbjni-java-only/0.0.3/fbjni-java-only-0.0.3.pom
       - file:/Users/devloops/.m2/repository/com/facebook/fbjni/fbjni-java-only/0.0.3/fbjni-java-only-0.0.3.pom
       - file:/Users/devloops/Desktop/maple/mobile/node_modules/react-native/android/com/facebook/fbjni/fbjni-java-only/0.0.3/fbjni-java-only-0.0.3.pom
       - file:/Users/devloops/Desktop/maple/mobile/node_modules/jsc-android/dist/com/facebook/fbjni/fbjni-java-only/0.0.3/fbjni-java-only-0.0.3.pom
       - https://dl.google.com/dl/android/maven2/com/facebook/fbjni/fbjni-java-only/0.0.3/fbjni-java-only-0.0.3.pom
       - https://www.jitpack.io/com/facebook/fbjni/fbjni-java-only/0.0.3/fbjni-java-only-0.0.3.pom
       - https://maven.google.com/com/facebook/fbjni/fbjni-java-only/0.0.3/fbjni-java-only-0.0.3.pom
     Required by:
         project :app > com.facebook.react:react-native:0.64.1
   > Could not find com.yqritc:android-scalablevideoview:1.0.4.
     Searched in the following locations:
       - https://repo.maven.apache.org/maven2/com/yqritc/android-scalablevideoview/1.0.4/android-scalablevideoview-1.0.4.pom
       - file:/Users/devloops/.m2/repository/com/yqritc/android-scalablevideoview/1.0.4/android-scalablevideoview-1.0.4.pom
       - file:/Users/devloops/Desktop/maple/mobile/node_modules/react-native/android/com/yqritc/android-scalablevideoview/1.0.4/android-scalablevideoview-1.0.4.pom
       - file:/Users/devloops/Desktop/maple/mobile/node_modules/jsc-android/dist/com/yqritc/android-scalablevideoview/1.0.4/android-scalablevideoview-1.0.4.pom
       - https://dl.google.com/dl/android/maven2/com/yqritc/android-scalablevideoview/1.0.4/android-scalablevideoview-1.0.4.pom
       - https://www.jitpack.io/com/yqritc/android-scalablevideoview/1.0.4/android-scalablevideoview-1.0.4.pom
       - https://maven.google.com/com/yqritc/android-scalablevideoview/1.0.4/android-scalablevideoview-1.0.4.pom
     Required by:
         project :app > project :react-native-video

* Try:
Run with --stacktrace option to get the stack trace. Run with --info or --debug option to get more log output. Run with --scan to get full insights.

* Get more help at https://help.gradle.org

BUİLD FAILED in 1m 7s

    at makeError (/Users/devloops/Desktop/maple/mobile/node_modules/execa/index.js:174:9)
    at /Users/devloops/Desktop/maple/mobile/node_modules/execa/index.js:278:16
    at processTicksAndRejections (node:internal/process/task_queues:96:5)
    at async runOnAllDevices (/Users/devloops/Desktop/maple/mobile/node_modules/@react-native-community/cli-platform-android/build/commands/runAndroid/runOnAllDevices.js:94:5)
    at async Command.handleAction (/Users/devloops/Desktop/maple/mobile/node_modules/@react-native-community/cli/build/index.js:186:9)
info Run CLI with --verbose flag for more details.
error Command failed with exit code 1.
info Visit https://yarnpkg.com/en/docs/cli/run for documentation about this command.

To Reproduce

I tried all versions up to 75 but I couldn't get a successful compilation. When compiling, I cannot get the relevant packages from the remote server. So I can't start build on android

Environment

System:
    OS: macOS 11.3.1
    CPU: (12) x64 Intel(R) Core(TM) i7-9750H CPU @ 2.60GHz
    Memory: 196.04 MB / 32.00 GB
    Shell: 5.8 - /bin/zsh
  Binaries:
    Node: 16.0.0 - /usr/local/bin/node
    Yarn: 1.22.10 - /usr/local/bin/yarn
    npm: 7.11.2 - /usr/local/bin/npm
    Watchman: 4.9.0 - /usr/local/bin/watchman
  Managers:
    CocoaPods: 1.10.1 - /usr/local/bin/pod
  SDKs:
    iOS SDK:
      Platforms: iOS 14.5, DriverKit 20.4, macOS 11.3, tvOS 14.5, watchOS 7.4
    Android SDK:
      API Levels: 29
      Build Tools: 28.0.3, 29.0.2, 29.0.3, 30.0.2
      System Images: android-29 | Intel x86 Atom_64, android-29 | Google APIs Intel x86 Atom, android-29 | Google APIs Intel x86 Atom_64, android-30 | Google APIs Intel x86 Atom_64
      Android NDK: Not Found
  IDEs:
    Android Studio: 4.2 AI-202.7660.26.42.7351085
    Xcode: 12.5/12E262 - /usr/bin/xcodebuild
  Languages:
    Java: 1.8.0_275 - /usr/bin/javac
  npmPackages:
    @react-native-community/cli: Not Found
    react: 17.0.2 => 17.0.2 
    react-native: ^0.64.1 => 0.64.1 
    react-native-macos: Not Found
  npmGlobalPackages:
    *react-native*: Not Found

Rc85
Rc85

Did you fix this? I am getting this error if I am using mavenCentral and running in development. If I use jcenter, all is good. But jcenter is being removed soon.

Jan
18
4 days ago
Activity icon
issue

Rc85 issue react-native-maps/react-native-maps

Rc85
Rc85

Zoom messes with map boundaries?

Bug report

Summary

Not sure if this is intended but it seems like the coordinates supplied to setMapBoundaries is setting the size of the view port rather than the how far north/south/west/east your view port can go.

Screenshot_20220118-122204_MT Drivers

Notice the boundary shown by the arrow and notice where Pitt Meadows is.

Screenshot_20220118-122242_MT Drivers

The red arrow here is the most I can scroll to, which is not the boundary that I have set. It's way far left than the one shown in the first picture. Notice where Pitt Meadows is in this picture. I should be able to scroll to the right more to see Golden Ears Provincial Park.

Environment info

react-native info output:

npmPackages: @react-native-community/cli: Not Found react: 16.13.1 => 16.13.1 react-native: ^0.66.1 => 0.66.1 react-native-windows: Not Found npmGlobalPackages: react-native: Not Found "react-native-maps": "^0.27.1",

# paste your react, react-native, react-native-maps versions here

Steps to reproduce

  1. Set map boundaries
  2. Scroll map to edge of any boundary.
  3. Zoom in.

Describe what you expected to happen:

You should always be able to reach the specified boundary no matter how zoomed in you are.

Describe what you actually happens:

You cannot scroll to the specified boundaries if you zoom in past a point.

Reproducible sample code

Jan
17
5 days ago
Activity icon
issue

Rc85 issue comment mauron85/react-native-background-geolocation

Rc85
Rc85

hello there some problem with repository Jcenter this repasitory will be died in february, and if i remove this plugin gave this error

  • What went wrong: Execution failed for task ':app:checkDebugAarMetadata'.
  • Could not resolve all files for configuration ':app:debugRuntimeClasspath'.

  • Could not find com.intentfilter:android-permissions:0.1.7.
  • Searched in the following locations:        
    
Rc85
Rc85

Having the same issue

Jan
16
6 days ago
Activity icon
issue

Rc85 issue comment stripe/stripe-react-native

Rc85
Rc85

Closing Apple Pay Sheet

Just the way you can use presentApplePay is there any way or method for closing it?

Rc85
Rc85

My apple pay sheet doesn't close by itself after payment method is created. It's stuck in Processing.

Jan
15
1 week ago
Activity icon
issue

Rc85 issue stripe/stripe-react-native

Rc85
Rc85

FATAL EXCEPTION: DefaultDispatcher-worker-7 when adding a payment method

Describe the bug App crashes with fatal exception when adding a payment method using CardField

To Reproduce Steps to reproduce the behavior:

  1. Add payment method using CardField

Expected behavior Should create a payment method

Screenshots If applicable, add screenshots to help explain your problem.

Desktop (please complete the following information):

  • OS: Windows 10
  • Browser [e.g. chrome, safari]
  • Version [e.g. 22]

Smartphone (please complete the following information):

  • Device: Samsung Galaxy S7
  • OS: Android 8
  • Browser [e.g. stock browser, safari]
  • Version [e.g. 22]
react-native 0.66.4
@stripe/stripe-react-native 0.2.3

Additional context

FATAL EXCEPTION: DefaultDispatcher-worker-7
Process: com.my_takeouts, PID: 12455
java.lang.AbstractMethodError: abstract method "void com.stripe.android.ApiResultCallback.onSuccess(com.stripe.android.core.model.StripeModel)"
	at com.stripe.android.Stripe$dispatchResult$2.invokeSuspend(Stripe.kt:1661)
	at kotlin.coroutines.jvm.internal.BaseContinuationImpl.resumeWith(ContinuationImpl.kt:33)
	at kotlinx.coroutines.DispatchedTask.run(DispatchedTask.kt:106)
	at android.os.Handler.handleCallback(Handler.java:789)
	at android.os.Handler.dispatchMessage(Handler.java:98)
	at android.os.Looper.loop(Looper.java:164)
	at android.app.ActivityThread.main(ActivityThread.java:6944)
	at java.lang.reflect.Method.invoke(Native Method)
	at com.android.internal.os.Zygote$MethodAndArgsCaller.run(Zygote.java:327)
	at com.android.internal.os.ZygoteInit.main(ZygoteInit.java:1374)

It was working fine until I try to implement Google Pay. Updated my app/build.gradle, AndroidManfiest.xml, and build.gradle.

Added mavenCentral() to buildscript -> repositories. Added

implementation 'com.google.android.gms:play-services-wallet:19.0.1'
implementation 'com.stripe:stripe-android:19.1.0'

to app/build.gradle Added <meta-data android:name="com.google.android.gms.wallet.api.enabled" android:value="true" /> to AndroidManifest.xml.

Implemented Google pay using initGooglePay in useEffect. Then, I have a button that calls createGooglePayPaymentMethod to create payment method.

Then I tried adding a 3DS card and thought maybe it's the authentication model crashing my app. Then I tried using 4000 0000 0000 0077 like I regularly would, and it's still crashing. The only other thing I remember changing was the urlScheme prop in <StripeProvider>, but changing it back didn't fix anything.

Activity icon
issue

Rc85 issue comment stripe/stripe-react-native

Rc85
Rc85

FATAL EXCEPTION: DefaultDispatcher-worker-7 when adding a payment method

Describe the bug App crashes with fatal exception when adding a payment method using CardField

To Reproduce Steps to reproduce the behavior:

  1. Add payment method using CardField

Expected behavior Should create a payment method

Screenshots If applicable, add screenshots to help explain your problem.

Desktop (please complete the following information):

  • OS: Windows 10
  • Browser [e.g. chrome, safari]
  • Version [e.g. 22]

Smartphone (please complete the following information):

  • Device: Samsung Galaxy S7
  • OS: Android 8
  • Browser [e.g. stock browser, safari]
  • Version [e.g. 22]
react-native 0.66.4
@stripe/stripe-react-native 0.2.3

Additional context

FATAL EXCEPTION: DefaultDispatcher-worker-7
Process: com.my_takeouts, PID: 12455
java.lang.AbstractMethodError: abstract method "void com.stripe.android.ApiResultCallback.onSuccess(com.stripe.android.core.model.StripeModel)"
	at com.stripe.android.Stripe$dispatchResult$2.invokeSuspend(Stripe.kt:1661)
	at kotlin.coroutines.jvm.internal.BaseContinuationImpl.resumeWith(ContinuationImpl.kt:33)
	at kotlinx.coroutines.DispatchedTask.run(DispatchedTask.kt:106)
	at android.os.Handler.handleCallback(Handler.java:789)
	at android.os.Handler.dispatchMessage(Handler.java:98)
	at android.os.Looper.loop(Looper.java:164)
	at android.app.ActivityThread.main(ActivityThread.java:6944)
	at java.lang.reflect.Method.invoke(Native Method)
	at com.android.internal.os.Zygote$MethodAndArgsCaller.run(Zygote.java:327)
	at com.android.internal.os.ZygoteInit.main(ZygoteInit.java:1374)

It was working fine until I try to implement Google Pay. Updated my app/build.gradle, AndroidManfiest.xml, and build.gradle.

Added mavenCentral() to buildscript -> repositories. Added

implementation 'com.google.android.gms:play-services-wallet:19.0.1'
implementation 'com.stripe:stripe-android:19.1.0'

to app/build.gradle Added <meta-data android:name="com.google.android.gms.wallet.api.enabled" android:value="true" /> to AndroidManifest.xml.

Implemented Google pay using initGooglePay in useEffect. Then, I have a button that calls createGooglePayPaymentMethod to create payment method.

Then I tried adding a 3DS card and thought maybe it's the authentication model crashing my app. Then I tried using 4000 0000 0000 0077 like I regularly would, and it's still crashing. The only other thing I remember changing was the urlScheme prop in <StripeProvider>, but changing it back didn't fix anything.

Rc85
Rc85

Removed implementation 'com.stripe:stripe-android:19.1.0' And issue is gone.

Jan
14
1 week ago
Activity icon
issue

Rc85 issue stripe/stripe-react-native

Rc85
Rc85

FATAL EXCEPTION: DefaultDispatcher-worker-7 when adding a payment method

Describe the bug App crashes with fatal exception when adding a payment method using CardField

To Reproduce Steps to reproduce the behavior:

  1. Add payment method using CardField

Expected behavior Should create a payment method

Screenshots If applicable, add screenshots to help explain your problem.

Desktop (please complete the following information):

  • OS: Windows 10
  • Browser [e.g. chrome, safari]
  • Version [e.g. 22]

Smartphone (please complete the following information):

  • Device: Samsung Galaxy S7
  • OS: Android 8
  • Browser [e.g. stock browser, safari]
  • Version [e.g. 22]
react-native 0.66.4
@stripe/stripe-react-native 0.2.3

Additional context

FATAL EXCEPTION: DefaultDispatcher-worker-7
Process: com.my_takeouts, PID: 12455
java.lang.AbstractMethodError: abstract method "void com.stripe.android.ApiResultCallback.onSuccess(com.stripe.android.core.model.StripeModel)"
	at com.stripe.android.Stripe$dispatchResult$2.invokeSuspend(Stripe.kt:1661)
	at kotlin.coroutines.jvm.internal.BaseContinuationImpl.resumeWith(ContinuationImpl.kt:33)
	at kotlinx.coroutines.DispatchedTask.run(DispatchedTask.kt:106)
	at android.os.Handler.handleCallback(Handler.java:789)
	at android.os.Handler.dispatchMessage(Handler.java:98)
	at android.os.Looper.loop(Looper.java:164)
	at android.app.ActivityThread.main(ActivityThread.java:6944)
	at java.lang.reflect.Method.invoke(Native Method)
	at com.android.internal.os.Zygote$MethodAndArgsCaller.run(Zygote.java:327)
	at com.android.internal.os.ZygoteInit.main(ZygoteInit.java:1374)

It was working fine until I try to implement Google Pay. Updated my app/build.gradle, AndroidManfiest.xml, and build.gradle.

Added mavenCentral() to buildscript -> repositories. Added

implementation 'com.google.android.gms:play-services-wallet:19.0.1'
implementation 'com.stripe:stripe-android:19.1.0'

to app/build.gradle Added <meta-data android:name="com.google.android.gms.wallet.api.enabled" android:value="true" /> to AndroidManifest.xml.

Implemented Google pay using initGooglePay in useEffect. Then, I have a button that calls createGooglePayPaymentMethod to create payment method.

Then I tried adding a 3DS card and thought maybe it's the authentication model crashing my app. Then I tried using 4000 0000 0000 0077 like I regularly would, and it's still crashing. The only other thing I remember changing was the urlScheme prop in <StripeProvider>, but changing it back didn't fix anything.

Activity icon
issue

Rc85 issue stripe/stripe-react-native

Rc85
Rc85

Anyway to use createGooglePaymentMethod in test mode?

It's showing my real credit card on my Google Pay and when I add it, it displays my real last 4 number and expiry date. Anyway to use this method in test mode?

Activity icon
issue

Rc85 issue comment facebook/flipper

Rc85
Rc85

No device found

Tried 0.127 and 0.126. Going back to 0.100, I can see Windows, my device and React Native (with metro connected).

SDK location is correct in settings. adb devices shows devices. What else should I do?

Rc85
Rc85

@Rc85 if you using Windows, download watchman and add the watchman path to the PATH environment variable

Watchman error is gone, but still no device found.

image

Jan
12
1 week ago
Activity icon
issue

Rc85 issue salsita/node-pg-migrate

Rc85
Rc85

pgm.dropColumn with cascade does not drop dependent objects

Code

pgm.dropColumn({ name: 'points', schema: 'app' }, 'email', { cascade: true });

Error

Error executing:
ALTER TABLE "app"."points"
  DROP "email";
error: cannot drop table app.points column email because other objects depend on it

Was previously using 5.9.0 and thought it might fixed in latest version, but after upgrading to 6.2.1, it didn't fix

Jan
3
2 weeks ago
Activity icon
issue

Rc85 issue comment microsoft/vscode

Rc85
Rc85

Annoying highlight after using suggestions

Does this issue occur when all extensions are disabled?: Yes/No

  • VS Code Version: 1.63.2
  • OS Version: Windows_NT x64 10.0.19042
  • Language Mode: Typescript React

Steps to Reproduce:

  1. Use a suggested autocomplete shown in the screenshot below

image

  1. The value field has this annoying highlight, similar to using a snippet where you define $1, $2 to tab your cursors to.

image

Why is this annoying? Because the code you type into the highlight area does not provide suggestions and autocompletes. May not be a bug and if there is a way to disable it, please advise.

Rc85
Rc85

After fiddling with the settings and added "editor.quickSuggestions": true, suggestions are showing up when cursor is in the highlighted area.

Activity icon
issue

Rc85 issue comment microsoft/vscode

Rc85
Rc85

Annoying highlight after using suggestions

Does this issue occur when all extensions are disabled?: Yes/No

  • VS Code Version: 1.63.2
  • OS Version: Windows_NT x64 10.0.19042
  • Language Mode: Typescript React

Steps to Reproduce:

  1. Use a suggested autocomplete shown in the screenshot below

image

  1. The value field has this annoying highlight, similar to using a snippet where you define $1, $2 to tab your cursors to.

image

Why is this annoying? Because the code you type into the highlight area does not provide suggestions and autocompletes. May not be a bug and if there is a way to disable it, please advise.

Rc85
Rc85

Is there a way to disable that highlight after selecting a suggestion? I remember it was never like this in older version of vscode. I would, say, tab on justify and the cursor would just move between the single quotes and I would type as normal.

Activity icon
issue

Rc85 issue comment microsoft/vscode

Rc85
Rc85

Annoying highlight after using suggestions

Does this issue occur when all extensions are disabled?: Yes/No

  • VS Code Version: 1.63.2
  • OS Version: Windows_NT x64 10.0.19042
  • Language Mode: Typescript React

Steps to Reproduce:

  1. Use a suggested autocomplete shown in the screenshot below

image

  1. The value field has this annoying highlight, similar to using a snippet where you define $1, $2 to tab your cursors to.

image

Why is this annoying? Because the code you type into the highlight area does not provide suggestions and autocompletes. May not be a bug and if there is a way to disable it, please advise.

Rc85
Rc85

Didn't work

Current behavior:

image

Press tab after suggesting justify image

Suggestions not showing image

Expected behavior:

Instead of pressing tab to select justify I typed the justify=''. Suggest popped up. image

Activity icon
issue

Rc85 issue jantimon/html-webpack-plugin

Rc85
Rc85

Injected variable wrapped with double quotes

Current behaviour 💣

Inject a string variable to my HTML file has double quotes around it.

Expected behaviour ☀️

Should not have double quotes.

Reproduction Example 👾

Environment 🖥

https://codesandbox.io/s/wild-night-mqm26?file=/webpack.config.js

  1. Create a new terminal
  2. Execute yarn start to run webpack serve
  3. Press refresh in the sandbox browser
  4. See "This is foo" wrapped in double quotes

The codesandbox uses webpack 5. The one I'm using in my development is webpack 4. Both have double quotes.

Activity icon
issue

Rc85 issue comment jantimon/html-webpack-plugin

Rc85
Rc85

Injected variable wrapped with double quotes

Current behaviour 💣

Inject a string variable to my HTML file has double quotes around it.

Expected behaviour ☀️

Should not have double quotes.

Reproduction Example 👾

Environment 🖥

https://codesandbox.io/s/wild-night-mqm26?file=/webpack.config.js

  1. Create a new terminal
  2. Execute yarn start to run webpack serve
  3. Press refresh in the sandbox browser
  4. See "This is foo" wrapped in double quotes

The codesandbox uses webpack 5. The one I'm using in my development is webpack 4. Both have double quotes.

Rc85
Rc85

JSON.stringify adds the double quote.

Activity icon
issue

Rc85 issue jantimon/html-webpack-plugin

Rc85
Rc85

Injected variable wrapped with double quotes

Current behaviour 💣

Inject a string variable to my HTML file has double quotes around it.

Expected behaviour ☀️

Should not have double quotes.

Reproduction Example 👾

Environment 🖥

https://codesandbox.io/s/wild-night-mqm26?file=/webpack.config.js

  1. Create a new terminal
  2. Execute yarn start to run webpack serve
  3. Press refresh in the sandbox browser
  4. See "This is foo" wrapped in double quotes

The codesandbox uses webpack 5. The one I'm using in my development is webpack 4. Both have double quotes.

Dec
31
3 weeks ago
Activity icon
issue

Rc85 issue comment facebook/flipper

Rc85
Rc85

No device found

Tried 0.127 and 0.126. Going back to 0.100, I can see Windows, my device and React Native (with metro connected).

SDK location is correct in settings. adb devices shows devices. What else should I do?

Dec
29
3 weeks ago
Activity icon
issue

Rc85 issue microsoft/vscode

Rc85
Rc85

Annoying highlight after using suggestions

Does this issue occur when all extensions are disabled?: Yes/No

  • VS Code Version: 1.63.2
  • OS Version: Windows_NT x64 10.0.19042
  • Language Mode: Typescript React

Steps to Reproduce:

  1. Use a suggested autocomplete shown in the screenshot below

image

  1. The value field has this annoying highlight, similar to using a snippet where you define $1, $2 to tab your cursors to.

image

Why is this annoying? Because the code you type into the highlight area does not provide suggestions and autocompletes. May not be a bug and if there is a way to disable it, please advise.

Dec
26
3 weeks ago
Activity icon
issue

Rc85 issue comment facebook/hermes

Rc85
Rc85

RN0.64 Android crash with Hermes Debugger in Flipper

Bug Description

I'm trying to use the Hermes Debugger in Flipper on an existing RN0.64 app which we recently tried to use Hermes on.

  • I have run gradle clean and confirmed this bug does not occur with JSC

Hermes version: Same as RN 0.64 React Native version (if any): 0.64 OS version (if any): Android 11 Platform (most likely one of arm64-v8a, armeabi-v7a, x86, x86_64):

Steps To Reproduce

  1. Start app on device.
  2. Go to Hermes Debugger (RN) in Flipper
  3. Crashes with Fatal signal 11 (SIGSEGV), code 1 (SEGV_MAPERR), fault addr 0x0 in tid 32085 (Thread-13)

The crash dump shows:

signal 11 (SIGSEGV), code 1 (SEGV_MAPERR), fault addr 0x0
Cause: null pointer dereference
#00 pc 000000000001d8d8 /data/app/~~XKMe7YzatnzZ3bppE8Hs3g==/com.app-JpLF1sF9vptsqfIbCTNcRw==/lib/arm64/libhermes-executor-common-debug.so (BuildId: f45383ff790ccc1692f3c61165ee8f75d3d66eaf)
#01 pc 00000000001e7efc /data/app/~~XKMe7YzatnzZ3bppE8Hs3g==/com.app-JpLF1sF9vptsqfIbCTNcRw==/lib/arm64/libhermes.so (BuildId: 6f52702204565e62fc1d0d9a58755bb7a4b543a7)
#02 pc 00000000001e7e68 /data/app/~~XKMe7YzatnzZ3bppE8Hs3g==/com.app-JpLF1sF9vptsqfIbCTNcRw==/lib/arm64/libhermes.so (BuildId: 6f52702204565e62fc1d0d9a58755bb7a4b543a7)
#03 pc 000000000013ced4 /apex/com.android.art/lib64/libart.so (art_quick_generic_jni_trampoline+148) (BuildId: 91ea3336584f5c23cca0c4a4a9b7d164)
#04 pc 0000000000133564 /apex/com.android.art/lib64/libart.so (art_quick_invoke_stub+548) (BuildId: 91ea3336584f5c23cca0c4a4a9b7d164)
#05 pc 00000000001a8a78 /apex/com.android.art/lib64/libart.so (art::ArtMethod::Invoke(art::Thread*, unsigned int*, unsigned int, art::JValue*, char const*)+200) (BuildId: 91ea3336584f5c23cca0c4a4a9b7d164)
#06 pc 0000000000318278 /apex/com.android.art/lib64/libart.so (art::interpreter::ArtInterpreterToCompiledCodeBridge(art::Thread*, art::ArtMethod*, art::ShadowFrame*, unsigned short, art::JValue*)+376) (BuildId: 91ea3336584f5c23cca0c4a4a9b7d164)
#07 pc 000000000030e5a4 /apex/com.android.art/lib64/libart.so (bool art::interpreter::DoCall<false, false>(art::ArtMethod*, art::Thread*, art::ShadowFrame&, art::Instruction const*, unsigned short, art::JValue*)+996) (BuildId: 91ea3336584f5c23cca0c4a4a9b7d164)
#08 pc 000000000067e9ac /apex/com.android.art/lib64/libart.so (MterpInvokeInterface+1032) (BuildId: 91ea3336584f5c23cca0c4a4a9b7d164)
#09 pc 000000000012da14 /apex/com.android.art/lib64/libart.so (mterp_op_invoke_interface+20) (BuildId: 91ea3336584f5c23cca0c4a4a9b7d164)
#10 pc 00000000000eb89c /apex/com.android.art/javalib/core-oj.jar (java.lang.Thread.run+8)
#11 pc 0000000000305ba0 /apex/com.android.art/lib64/libart.so (art::interpreter::Execute(art::Thread*, art::CodeItemDataAccessor const&, art::ShadowFrame&, art::JValue, bool, bool) (.llvm.3685415019599751405)+268) (BuildId: 91ea3336584f5c23cca0c4a4a9b7d164)
#12 pc 000000000066bcf4 /apex/com.android.art/lib64/libart.so (artQuickToInterpreterBridge+780) (BuildId: 91ea3336584f5c23cca0c4a4a9b7d164)
#13 pc 000000000013cff8 /apex/com.android.art/lib64/libart.so (art_quick_to_interpreter_bridge+88) (BuildId: 91ea3336584f5c23cca0c4a4a9b7d164)
#14 pc 0000000000133564 /apex/com.android.art/lib64/libart.so (art_quick_invoke_stub+548) (BuildId: 91ea3336584f5c23cca0c4a4a9b7d164)
#15 pc 00000000001a8a78 /apex/com.android.art/lib64/libart.so (art::ArtMethod::Invoke(art::Thread*, unsigned int*, unsigned int, art::JValue*, char const*)+200) (BuildId: 91ea3336584f5c23cca0c4a4a9b7d164)
#16 pc 00000000005557a8 /apex/com.android.art/lib64/libart.so (art::JValue art::InvokeVirtualOrInterfaceWithJValues<art::ArtMethod*>(art::ScopedObjectAccessAlreadyRunnable const&, _jobject*, art::ArtMethod*, jvalue const*)+460) (BuildId: 91ea3336584f5c23cca0c4a4a9b7d164)
#17 pc 00000000005a4b0c /apex/com.android.art/lib64/libart.so (art::Thread::CreateCallback(void*)+1308) (BuildId: 91ea3336584f5c23cca0c4a4a9b7d164)
#18 pc 00000000000da278 /apex/com.android.runtime/lib64/bionic/libc.so (__pthread_start(void*)+64) (BuildId: 1ca28d785d6567d2b225cf978ef04de5)
#19 pc 000000000007a448 /apex/com.android.runtime/lib64/bionic/libc.so (__start_thread+64) (BuildId: 1ca28d785d6567d2b225cf978ef04de5)

Not sure how to get the tombstone file from the phone, as it isn't rooted.

Rc85
Rc85

@WNemencha Can you confirm that you are still seeing this issue with the latest version of reanimated? The corresponding issue in reanimated seems to have been closed a few days ago: software-mansion/react-native-reanimated#1923

If so, are you able to provide a symbolicated stack trace?

It's still happening to me. I tried with hermes enabled and disabled and both crashes my app when I turn on remote debugging. Here is what I can scrape from adb logcat.

FATAL EXCEPTION: mqt_js
12-26 00:55:09.492 19046 19456 E AndroidRuntime: Process: com.my_takeouts, PID: 19046
12-26 00:55:09.492 19046 19456 E AndroidRuntime: java.lang.AssertionError: No source URL loaded, have you initialised the instance?
12-26 00:55:09.492 19046 19456 E AndroidRuntime:        at com.facebook.infer.annotation.Assertions.assertNotNull(Assertions.java:19)
12-26 00:55:09.492 19046 19456 E AndroidRuntime:        at com.facebook.react.modules.debug.SourceCodeModule.getTypedExportedConstants(SourceCodeModule.java:39)
12-26 00:55:09.492 19046 19456 E AndroidRuntime:        at com.facebook.fbreact.specs.NativeSourceCodeSpec.getConstants(NativeSourceCodeSpec.java:38)
12-26 00:55:09.492 19046 19456 E AndroidRuntime:        at com.facebook.react.bridge.JavaModuleWrapper.getConstants(JavaModuleWrapper.java:142)
12-26 00:55:09.492 19046 19456 E AndroidRuntime:        at com.facebook.react.bridge.queue.NativeRunnable.run(Native Method)
12-26 00:55:09.492 19046 19456 E AndroidRuntime:        at android.os.Handler.handleCallback(Handler.java:883)
12-26 00:55:09.492 19046 19456 E AndroidRuntime:        at android.os.Handler.dispatchMessage(Handler.java:100)
12-26 00:55:09.492 19046 19456 E AndroidRuntime:        at com.facebook.react.bridge.queue.MessageQueueThreadHandler.dispatchMessage(MessageQueueThreadHandler.java:27)
12-26 00:55:09.492 19046 19456 E AndroidRuntime:        at android.os.Looper.loop(Looper.java:237)
12-26 00:55:09.492 19046 19456 E AndroidRuntime:        at com.facebook.react.bridge.queue.MessageQueueThreadImpl$4.run(MessageQueueThreadImpl.java:226)
12-26 00:55:09.492 19046 19456 E AndroidRuntime:        at java.lang.Thread.run(Thread.java:919)
...
12-26 00:55:09.507   946   976 D Debug   : [email protected] : SHIP
12-26 00:55:09.507   946   976 D Debug   : [email protected] : debug level:0x4f4c
12-26 00:55:09.507   946   976 D Debug   : [email protected] : Finally, system will skip dumpstate
12-26 00:55:09.510   946   976 W ActivityManager: crash : com.my_takeouts,0
12-26 00:55:09.514   946   976 W ActivityTaskManager:   Force finishing activity com.my_takeouts/.MainActivity
12-26 00:55:09.515   946   976 D ActivityTaskManager: updateMinimizedState: unknown notifyReason=2
...
12-26 00:55:09.741 19460 19460 F DEBUG   :
12-26 00:55:09.741 19460 19460 F DEBUG   : backtrace:
12-26 00:55:09.742  6960  6960 D [email protected][]: Relayout returned: old=(400,0,400,1280) new=(400,0,400,1280) req=(0,1280)8 dur=10 res=0x1 s={false 0} ch=false
12-26 00:55:09.742 19460 19460 F DEBUG   :       #00 pc 0011c9a4  /data/app/com.my_takeouts-I7rVcmInB-FCq2RpwGI25w==/base.apk!libreanimated.so (offset 0x340e000) (reanimated::NativeProxy::installJSIBindings()+160) (BuildId: cfd598869a5136943d0a504c359ab3c97ef9f8d5)
12-26 00:55:09.742  4975  4975 D PageOverlayMover: updateActivityLifecycleState : 1
12-26 00:55:09.742 19460 19460 F DEBUG   :       #01 pc 00139624  /data/app/com.my_takeouts-I7rVcmInB-FCq2RpwGI25w==/base.apk!libreanimated.so (offset 0x340e000) (_ZN8facebook3jni6detail13MethodWrapperIMN10reanimated11NativeProxyEFvvEXadL_ZNS4_18installJSIBindingsEvEES4_vJEE8dispatchENS0_9alias_refIPNS1_8JTypeForINS0_11HybridClassIS4_NS1_15BaseHybridClassEE8JavaPartENS0_7JObjectEvE11_javaobjectEEE+172) (BuildId: cfd598869a5136943d0a504c359ab3c97ef9f8d5)
12-26 00:55:09.743 19460 19460 F DEBUG   :       #02 pc 001396a0  /data/app/com.my_takeouts-I7rVcmInB-FCq2RpwGI25w==/base.apk!libreanimated.so (offset 0x340e000) (_ZN8facebook3jni6detail22CallWithJniConversionsIPFvNS0_9alias_refIPNS1_8JTypeForINS0_11HybridClassIN10reanimated11NativeProxyENS1_15BaseHybridClassEE8JavaPartENS0_7JObjectEvE11_javaobjectEEEEvSE_JEE4callESE_SH_+60) (BuildId: cfd598869a5136943d0a504c359ab3c97ef9f8d5)
12-26 00:55:09.743  4975  4975 D LiveIconViewUpdater: onUpdateLiveIcon 32
12-26 00:55:09.743 19460 19460 F DEBUG   :       #03 pc 001394e4  /data/app/com.my_takeouts-I7rVcmInB-FCq2RpwGI25w==/base.apk!libreanimated.so (offset 0x340e000) (_ZN8facebook3jni6detail15FunctionWrapperIPFvNS0_9alias_refIPNS1_8JTypeForINS0_11HybridClassIN10reanimated11NativeProxyENS1_15BaseHybridClassEE8JavaPartENS0_7JObjectEvE11_javaobjectEEEESE_vJEE4callEP7_JNIEnvP8_jobjectSH_+44) (BuildId: cfd598869a5136943d0a504c359ab3c97ef9f8d5)
12-26 00:55:09.743 19460 19460 F DEBUG   :       #04 pc 001312c8  /data/app/com.my_takeouts-I7rVcmInB-FCq2RpwGI25w==/base.apk!libreanimated.so (offset 0x340e000) (_ZN8facebook3jni6detail13MethodWrapperIMN10reanimated11NativeProxyEFvvEXadL_ZNS4_18installJSIBindingsEvEES4_vJEE4callEP7_JNIEnvP8_jobject+36) (BuildId: cfd598869a5136943d0a504c359ab3c97ef9f8d5)
12-26 00:55:09.744  4975  4975 D LiveIconViewUpdater: onUpdateLiveIcon -1
12-26 00:55:09.745 19460 19460 F DEBUG   :       #05 pc 000dc519  /apex/com.android.runtime/lib/libart.so (art_quick_generic_jni_trampoline+40) (BuildId: 16c641c14a01ea3d297b42480c523cef)
12-26 00:55:09.745 19460 19460 F DEBUG   :       #06 pc 000d7bc5  /apex/com.android.runtime/lib/libart.so (art_quick_invoke_stub_internal+68) (BuildId: 16c641c14a01ea3d297b42480c523cef)
12-26 00:55:09.745 19460 19460 F DEBUG   :       #07 pc 00436fb5  /apex/com.android.runtime/lib/libart.so (art_quick_invoke_stub+252) (BuildId: 16c641c14a01ea3d297b42480c523cef)
12-26 00:55:09.745 19460 19460 F DEBUG   :       #08 pc 000dffeb  /apex/com.android.runtime/lib/libart.so (art::ArtMethod::Invoke(art::Thread*, unsigned int*, unsigned int, art::JValue*, char const*)+178) (BuildId: 16c641c14a01ea3d297b42480c523cef)
12-26 00:55:09.745 19460 19460 F DEBUG   :       #09 pc 00213875  /apex/com.android.runtime/lib/libart.so (art::interpreter::ArtInterpreterToCompiledCodeBridge(art::Thread*, art::ArtMethod*, art::ShadowFrame*, unsigned short, art::JValue*)+280) (BuildId: 16c641c14a01ea3d297b42480c523cef)
12-26 00:55:09.746 19460 19460 F DEBUG   :       #10 pc 0020f18d  /apex/com.android.runtime/lib/libart.so (bool art::interpreter::DoCall<false, false>(art::ArtMethod*, art::Thread*, art::ShadowFrame&, art::Instruction const*, unsigned short, art::JValue*)+716) (BuildId: 16c641c14a01ea3d297b42480c523cef)
12-26 00:55:09.746 19460 19460 F DEBUG   :       #11 pc 0042e04b  /apex/com.android.runtime/lib/libart.so (MterpInvokeDirect+378) (BuildId: 16c641c14a01ea3d297b42480c523cef)
12-26 00:55:09.746 19460 19460 F DEBUG   :       #12 pc 000d2914  /apex/com.android.runtime/lib/libart.so (mterp_op_invoke_direct+20) (BuildId: 16c641c14a01ea3d297b42480c523cef)
12-26 00:55:09.746 19460 19460 F DEBUG   :       #13 pc 0006afec  [anon:dalvik-classes2.dex extracted in memory from /data/app/com.my_takeouts-I7rVcmInB-FCq2RpwGI25w==/base.apk!classes2.dex] (com.swmansion.reanimated.NativeProxy.prepare+44)
12-26 00:55:09.746 19460 19460 F DEBUG   :       #14 pc 0042c461  /apex/com.android.runtime/lib/libart.so (MterpInvokeVirtual+1192) (BuildId: 16c641c14a01ea3d297b42480c523cef)
12-26 00:55:09.746 19460 19460 F DEBUG   :       #15 pc 000d2814  /apex/com.android.runtime/lib/libart.so (mterp_op_invoke_virtual+20) (BuildId: 16c641c14a01ea3d297b42480c523cef)
12-26 00:55:09.747 19460 19460 F DEBUG   :       #16 pc 0006af42  [anon:dalvik-classes2.dex extracted in memory from /data/app/com.my_takeouts-I7rVcmInB-FCq2RpwGI25w==/base.apk!classes2.dex] (com.swmansion.reanimated.NativeProxy.<init>+114)
12-26 00:55:09.747 19460 19460 F DEBUG   :       #17 pc 0042e293  /apex/com.android.runtime/lib/libart.so (MterpInvokeDirect+962) (BuildId: 16c641c14a01ea3d297b42480c523cef)
12-26 00:55:09.747 19460 19460 F DEBUG   :       #18 pc 000d2914  /apex/com.android.runtime/lib/libart.so (mterp_op_invoke_direct+20) (BuildId: 16c641c14a01ea3d297b42480c523cef)
12-26 00:55:09.747 19460 19460 F DEBUG   :       #19 pc 0006bf00  [anon:dalvik-classes2.dex extracted in memory from /data/app/com.my_takeouts-I7rVcmInB-FCq2RpwGI25w==/base.apk!classes2.dex] (com.swmansion.reanimated.NodesManager.initWithContext+4)
12-26 00:55:09.747 19460 19460 F DEBUG   :       #20 pc 0042c461  /apex/com.android.runtime/lib/libart.so (MterpInvokeVirtual+1192) (BuildId: 16c641c14a01ea3d297b42480c523cef)
12-26 00:55:09.747 19460 19460 F DEBUG   :       #21 pc 000d2814  /apex/com.android.runtime/lib/libart.so (mterp_op_invoke_virtual+20) (BuildId: 16c641c14a01ea3d297b42480c523cef)
12-26 00:55:09.747 19460 19460 F DEBUG   :       #22 pc 0006c48c  [anon:dalvik-classes2.dex extracted in memory from /data/app/com.my_takeouts-I7rVcmInB-FCq2RpwGI25w==/base.apk!classes2.dex] (com.swmansion.reanimated.ReanimatedJSIModulePackage.getJSIModules+24)
12-26 00:55:09.744  4975  4975 D LiveIconViewUpdater: onUpdateLiveIcon -1
12-26 00:55:09.747  4975  4975 D WallpapersButton: updateVisibility - mWallpaperType : 0
12-26 00:55:09.747 19460 19460 F DEBUG   :       #23 pc 0042d967  /apex/com.android.runtime/lib/libart.so (MterpInvokeInterface+1542) (BuildId: 16c641c14a01ea3d297b42480c523cef)
12-26 00:55:09.747 19460 19460 F DEBUG   :       #24 pc 000d2a14  /apex/com.android.runtime/lib/libart.so (mterp_op_invoke_interface+20) (BuildId: 16c641c14a01ea3d297b42480c523cef)
12-26 00:55:09.748 19460 19460 F DEBUG   :       #25 pc 001b852e  [anon:dalvik-classes6.dex extracted in memory from /data/app/com.my_takeouts-I7rVcmInB-FCq2RpwGI25w==/base.apk!classes6.dex] (com.facebook.react.ReactInstanceManager.createReactContext+346)
12-26 00:55:09.748 19460 19460 F DEBUG   :       #26 pc 0042e293  /apex/com.android.runtime/lib/libart.so (MterpInvokeDirect+962) (BuildId: 16c641c14a01ea3d297b42480c523cef)
12-26 00:55:09.748 19460 19460 F DEBUG   :       #27 pc 000d2914  /apex/com.android.runtime/lib/libart.so (mterp_op_invoke_direct+20) (BuildId: 16c641c14a01ea3d297b42480c523cef)
12-26 00:55:09.748 19460 19460 F DEBUG   :       #28 pc 001b83b8  [anon:dalvik-classes6.dex extracted in memory from /data/app/com.my_takeouts-I7rVcmInB-FCq2RpwGI25w==/base.apk!classes6.dex] (com.facebook.react.ReactInstanceManager.access$1100)
12-26 00:55:09.748 19460 19460 F DEBUG   :       #29 pc 0042e9d5  /apex/com.android.runtime/lib/libart.so (MterpInvokeStatic+932) (BuildId: 16c641c14a01ea3d297b42480c523cef)
12-26 00:55:09.748 19460 19460 F DEBUG   :       #30 pc 000d2994  /apex/com.android.runtime/lib/libart.so (mterp_op_invoke_static+20) (BuildId: 16c641c14a01ea3d297b42480c523cef)
12-26 00:55:09.748 19460 19460 F DEBUG   :       #31 pc 001b7ab8  [anon:dalvik-classes6.dex extracted in memory from /data/app/com.my_takeouts-I7rVcmInB-FCq2RpwGI25w==/base.apk!classes6.dex] (com.facebook.react.ReactInstanceManager$5.run+140)
12-26 00:55:09.748 19460 19460 F DEBUG   :       #32 pc 0042d967  /apex/com.android.runtime/lib/libart.so (MterpInvokeInterface+1542) (BuildId: 16c641c14a01ea3d297b42480c523cef)
12-26 00:55:09.749 19460 19460 F DEBUG   :       #33 pc 000d2a14  /apex/com.android.runtime/lib/libart.so (mterp_op_invoke_interface+20) (BuildId: 16c641c14a01ea3d297b42480c523cef)
12-26 00:55:09.749 19460 19460 F DEBUG   :       #34 pc 000eaa54  /apex/com.android.runtime/javalib/core-oj.jar (java.lang.Thread.run+8)
12-26 00:55:09.749 19460 19460 F DEBUG   :       #35 pc 001eeb79  /apex/com.android.runtime/lib/libart.so (_ZN3art11interpreterL7ExecuteEPNS_6ThreadERKNS_20CodeItemDataAccessorERNS_11ShadowFrameENS_6JValueEbb.llvm.2237354601837329179+192) (BuildId: 16c641c14a01ea3d297b42480c523cef)
12-26 00:55:09.749  4975  4975 D ThemesButton: updateVisibility - sThemeStoreType : -1
12-26 00:55:09.749  4975  4975 D LiveIconViewUpdater: onUpdateLiveIcon 63
12-26 00:55:09.749 19460 19460 F DEBUG   :       #36 pc 001f336b  /apex/com.android.runtime/lib/libart.so (art::interpreter::EnterInterpreterFromEntryPoint(art::Thread*, art::CodeItemDataAccessor const&, art::ShadowFrame*)+126) (BuildId: 16c641c14a01ea3d297b42480c523cef)
12-26 00:55:09.749  4975  4975 D LiveIconViewUpdater: onUpdateLiveIcon 66
12-26 00:55:09.749 19460 19460 F DEBUG   :       #37 pc 00420a9d  /apex/com.android.runtime/lib/libart.so (artQuickToInterpreterBridge+852) (BuildId: 16c641c14a01ea3d297b42480c523cef)
12-26 00:55:09.750 19460 19460 F DEBUG   :       #38 pc 000dc5a1  /apex/com.android.runtime/lib/libart.so (art_quick_to_interpreter_bridge+32) (BuildId: 16c641c14a01ea3d297b42480c523cef)
12-26 00:55:09.750 19460 19460 F DEBUG   :       #39 pc 000d7bc5  /apex/com.android.runtime/lib/libart.so (art_quick_invoke_stub_internal+68) (BuildId: 16c641c14a01ea3d297b42480c523cef)
12-26 00:55:09.750 19460 19460 F DEBUG   :       #40 pc 00436fb5  /apex/com.android.runtime/lib/libart.so (art_quick_invoke_stub+252) (BuildId: 16c641c14a01ea3d297b42480c523cef)
12-26 00:55:09.750 19460 19460 F DEBUG   :       #41 pc 000dffeb  /apex/com.android.runtime/lib/libart.so (art::ArtMethod::Invoke(art::Thread*, unsigned int*, unsigned int, art::JValue*, char const*)+178) (BuildId: 16c641c14a01ea3d297b42480c523cef)
12-26 00:55:09.750 19460 19460 F DEBUG   :       #42 pc 00377deb  /apex/com.android.runtime/lib/libart.so (art::(anonymous namespace)::InvokeWithArgArray(art::ScopedObjectAccessAlreadyRunnable const&, art::ArtMethod*, art::(anonymous namespace)::ArgArray*, art::JValue*, char const*)+54) (BuildId: 16c641c14a01ea3d297b42480c523cef)
12-26 00:55:09.751 19460 19460 F DEBUG   :       #43 pc 00378b73  /apex/com.android.runtime/lib/libart.so (art::InvokeVirtualOrInterfaceWithJValues(art::ScopedObjectAccessAlreadyRunnable const&, _jobject*, _jmethodID*, jvalue const*)+306) (BuildId: 16c641c14a01ea3d297b42480c523cef)
12-26 00:55:09.751 19460 19460 F DEBUG   :       #44 pc 003aa1bb  /apex/com.android.runtime/lib/libart.so (art::Thread::CreateCallback(void*)+982) (BuildId: 16c641c14a01ea3d297b42480c523cef)
12-26 00:55:09.751 19460 19460 F DEBUG   :       #45 pc 000abcdb  /apex/com.android.runtime/lib/bionic/libc.so (__pthread_start(void*)+20) (BuildId: 8f5d1631f046aa23ddeaa4c33901533c)
12-26 00:55:09.751 19460 19460 F DEBUG   :       #46 pc 00062d93  /apex/com.android.runtime/lib/bionic/libc.so (__start_thread+30) (BuildId: 8f5d1631f046aa23ddeaa4c33901533c)
Activity icon
issue

Rc85 issue facebook/flipper

Rc85
Rc85

No device found

Tried 0.127 and 0.126. Going back to 0.100, I can see Windows, my device and React Native (with metro connected).

SDK location is correct in settings. adb devices shows devices. What else should I do?

Dec
25
4 weeks ago
Activity icon
issue

Rc85 issue comment SortableJS/Sortable

Rc85
Rc85

[feature] drag to the list header

Scenario :

  • list 1 has x items
  • list 2 has y items
  • sidebar area shows the list names -> list 1, list 2
  • content area shows list 1

how to drag an item from list 1 to the sidebar list 2 header ?

[---------][-------------------------] list 1. |. list 1 item 1 list 2. |. list 1 item 2 (drag this item to list 2 on sidebar) list 3 |. list 1 item 3

In other words, instead of showing all items of every list, only one list is shown and it should be possible to drag an item to one of the sidebar list headers (names).

Rc85
Rc85

I'm also looking for something like this, except that category is also sortable. When using @dzero1 demo, pulling product to category will add product to category list. I want to be able to drop the product on top of a category and add to that category's product list. Is this achievable with just this library or do I need something like drop zone as well?

Dec
11
1 month ago
Activity icon
issue

Rc85 issue comment gorhom/react-native-bottom-sheet

Rc85
Rc85

[v4] Entire view being blocked by BottomSheetBackdrop

Bug

The first time it works as expected, but once I move to some other screen and come back, all touch events are blocked by the backdrop overlay. Though, the backdrop component is not visible at that time.

The same app is tested on Android and iOS, but the issue is only present on the Android device.

Environment info

Library Version
@gorhom/bottom-sheet 4
react-native expo: sdk-42.0.0
react-native-reanimated 2.2.0
react-native-gesture-handler 1.10.2

Device Details:

OS: Android 11 (MIUI Global 12.5.8 Stable) Model: Redmi Note 10 Pro (M2101K6P)

Steps To Reproduce

  1. Open the bottom sheet and close it
  2. Change to some other using stack navigator
  3. Come back to this page, touch events should be blocked.

Reproducible sample code

Its all from example code, still I'm adding the code here:

  const bottomSheetRef = useRef();
  const snapPoints = useMemo(() => ["80%"], []);

  const renderBackdrop = useCallback(
    (props) => (
      <BottomSheetBackdrop
        {...props}
        disappearsOnIndex={-1}
        appearsOnIndex={0}
        enableTouchThrough={true}
      />
    ),
    []
  );

  return (
  <KeyboardAvoidingView
      style={styles.groceriesParentView}
      behavior={Platform.OS === "ios" ? "padding" : null}>
      <SafeAreaView style={styles.container}>
        
        <BottomSheet
          ref={bottomSheetRef}
          index={-1}
          snapPoints={snapPoints}
          onChange={handleSheetChanges}
          enablePanDownToClose={true}
          backdropComponent={renderBackdrop}>
             <View>...<View/>
        </BottomSheet>

      </SafeAreaView>
    </KeyboardAvoidingView>
)
Rc85
Rc85

Using the Custom Backdrop example (https://gorhom.github.io/react-native-bottom-sheet/custom-backdrop) I saw the same problem.

I fixed it by adding pointerEvents="none" to the Animated.View in the example.

E.g return <Animated.View pointerEvents="none" style={containerStyle} />;

Does this fix it for you? @Prabindas001

This removes the capability to close the bottom sheet by pressing backdrop. It also introduces a "clickthrough" experience on the backdrop. In other words, pressing anywhere on the backdrop will interact with elements underneath it.

Activity icon
issue

Rc85 issue comment gorhom/react-native-bottom-sheet

Rc85
Rc85

[v4] Backdrop doesn't render when used single snap point

Single snap point doesn't render the backdrop. I'd only like to have a single snap point, however backdrop doesn't render with single snap point.

const snapPoints = useMemo(() => ['60%'], []); // doesn't work
const snapPoints = useMemo(() => ['10%', '60%'], []); // works

I added 0, but it says snapPoints 0 is not supported, use enablePanDownToClose instead.

...
const renderBackdrop = useCallback(
        (props) => <BottomSheetBackdrop {...props} pressBehavior="close" />,
        [],
    );
...

        <BottomSheet
            ref={bottomSheetRef}
            snapPoints={snapPoints}
            backdropComponent={renderBackdrop}
            index={-1}
            enablePanDownToClose={true}
            handleIndicatorStyle={styles.bottomSheetHandle}
            backgroundStyle={{ backgroundColor: 'red' }}
            {...otherProps}>
            {children(otherProps)}
        </BottomSheet>
Rc85
Rc85

I am having the same issue, but with custom backdrop and those props do not exist in Animated.View. What's the alternative solution for custom backdrops?

Dec
10
1 month ago
Activity icon
issue

Rc85 issue comment thiendangit/react-native-thermal-receipt-printer-image-qr

Rc85
Rc85

Documentation?

Can you add documentation on how to setup and print column?

Activity icon
issue

Rc85 issue thiendangit/react-native-thermal-receipt-printer-image-qr

Rc85
Rc85

Documentation?

Can you add documentation on how to setup and print column?

Activity icon
issue

Rc85 issue thiendangit/react-native-thermal-receipt-printer-image-qr

Rc85
Rc85

Documentation?

Can you add documentation on how to setup and print column?

Nov
28
1 month ago
Activity icon
issue

Rc85 issue comment software-mansion/react-native-reanimated

Rc85
Rc85

[before release] 2.2.1 crash with Hermes

09-06 18:46:31.430 26582 26582 F DEBUG   : signal 6 (SIGABRT), code -6 (SI_TKILL), fault addr --------
 Abort message: 'terminating with uncaught exception of type std::runtime_error: Unable to retrieve jni environment. Is the thread attached?'
    x0  0000000000000000  x1  0000000000006797  x2  0000000000000006  x3  0000000000000008
    x4  fefefefefefefeff  x5  fefefefefefefeff  x6  fefefefefefefeff  x7  7f7f7f7f7f7f7f7f
    x8  0000000000000083  x9  000000723b5fc838  x10 fffffff87ffffbdf  x11 0000000000000001
    x12 0000000000000018  x13 00000000613637d7  x14 000cf5758ce381de  x15 0000332465d8006e
    x16 000000723b6332a0  x17 000000723b572920  x18 0000000000000000  x19 0000000000006756
    x20 0000000000006797  x21 0000000000000083  x22 ffffff80ffffffc8  x23 000000718afb48c0
    x24 000000718afb47a0  x25 000000718afb47e0  x26 0000000000000052  x27 0000000000000001
    x28 00000000000009f8  x29 000000718afb4710
    sp  000000718afb46d0  lr  000000723b565d68  pc  000000723b565d94

 backtrace:
    #00 pc 0000000000021d94  /system/lib64/libc.so (abort+124)
    #01 pc 00000000000a01bc  /data/app/---/lib/arm64/libc++_shared.so
    #02 pc 00000000000a03b0  /data/app/---/lib/arm64/libc++_shared.so
    #03 pc 00000000000b4208  /data/app/---/lib/arm64/libc++_shared.so
    #04 pc 00000000000b41a0  /data/app/---/lib/arm64/libc++_shared.so (std::terminate()+36)
    #05 pc 00000000000b7c98  /data/app/---/lib/arm64/libreanimated.so
Rc85
Rc85

I am getting error when I try to debug remotely. My app crashes when I try to start it. Screenshot 2021-11-27 184604

I'ver added react-native-reanimated to babel config and added the import at the top of my application's entry file.

react-native 0.66.1 react-native-reanimated 2.2.3

Android 8 Developing on Windows 10

Nov
14
2 months ago
Activity icon
issue

Rc85 issue gorhom/react-native-bottom-sheet

Rc85
Rc85

[v4] | [v2] ScrollView inside Stack Navigator inside BottomSheet requires two fingers to scroll??

Bug

Title

Environment info

// omitted props
<BottomSheet enableOverDrag={false}>
  <Stack.Navigator>
    <Stack.Screen component={Screen} />
  </Stack.Navigator>
</BottomSheet>

const Screen = () => {
  return <ScrollView></ScrollView>
}

Unfortunately, I cannot wrap the navigator with a BottomSheetScrollView. The navigator won't show.

Library Version
@gorhom/bottom-sheet 4.1.3
react-native 0.66
react-native-reanimated 2.3.0-beta.2
react-native-gesture-handler 1.10.3
OS Android 10

Steps To Reproduce

  1. Build an app with the heirarchy shown above
  2. Try to scroll with one finger

Describe what you expected to happen:

  1. Tried to scroll ScrollView
  2. Cannot scroll. Can only scroll with two fingers.

Reproducible sample code

Activity icon
issue

Rc85 issue comment gorhom/react-native-bottom-sheet

Rc85
Rc85

[v4] | [v2] ScrollView inside Stack Navigator inside BottomSheet requires two fingers to scroll??

Bug

Title

Environment info

// omitted props
<BottomSheet enableOverDrag={false}>
  <Stack.Navigator>
    <Stack.Screen component={Screen} />
  </Stack.Navigator>
</BottomSheet>

const Screen = () => {
  return <ScrollView></ScrollView>
}

Unfortunately, I cannot wrap the navigator with a BottomSheetScrollView. The navigator won't show.

Library Version
@gorhom/bottom-sheet 4.1.3
react-native 0.66
react-native-reanimated 2.3.0-beta.2
react-native-gesture-handler 1.10.3
OS Android 10

Steps To Reproduce

  1. Build an app with the heirarchy shown above
  2. Try to scroll with one finger

Describe what you expected to happen:

  1. Tried to scroll ScrollView
  2. Cannot scroll. Can only scroll with two fingers.

Reproducible sample code

Rc85
Rc85

Blah, was using ScrollView from react-native. Using the one from react-native-gesture-handler and can scroll with one finger.

Previous