ZhymabekRoman

ZhymabekRoman

Linux user, classical gitarist/instrumentalist, Open Source enthusiast. I always push directly to master/main.

Member Since 1 year ago

Experience Points
13
follower
Lessons Completed
5
follow
Lessons Completed
347
stars
Best Reply Awards
24
repos

361 contributions in the last year

Pinned
⚡ Non official modified version of Exagear for Termux and proot based environemnts - Anlinux, AndroNix, UserLand and etc.
⚡ Non-official Platonus (Kazakhstan learning system) API wrapper | Неофициальная Python библиотека для работы с Платонусом
⚡ Unofficial instructions about installing Puffin Internet Terminal on Linux
⚡ A module grouping multiple translation APIs
⚡ Simple Cameyo Package extractor
⚡ My VIM config files
Activity
Dec
3
2 days ago
Dec
2
3 days ago
started
started time in 2 days ago
started
started time in 3 days ago
Dec
1
4 days ago
Nov
29
6 days ago
Activity icon
issue

ZhymabekRoman issue comment termux/proot

ZhymabekRoman
ZhymabekRoman

proot-distro alpine and xfce4

platrform

android 10, termux 0.117

Problem description

Unable to start xfce in alpine. Termux just crashes, and before that, a bunch of errors pops up ...

Steps to reproduce

pkg install proot-distro; proot-distro install alpine; proot-distro login alpine; Xvfb :1 -screen 0 1920x1080x24 & x11vnc -xkb -noxrecord -noxfixes -noxdamage -display :1 > -nopw -wait 5 -shared -permitfiletransfer -tightfilexfer -noshm & DISPLAY=:1 openbox & DISPLAY=:1 xfce4-terminal & DISPLAY=:1 startxfce4 & #4-session --display=:1

ZhymabekRoman
ZhymabekRoman

K. Can you describe in steps all the commands for installing a full-fledged xfce on termux alpine?

I have never installed xfce4 on Alpine linux, only on Debian-like systems. But such a problem also failed when using some VNC I have never installed xfce4 on Alpine linux, only on Debian-like systems. But such a problem also was when using some VNC servers

Nov
28
1 week ago
Activity icon
issue

ZhymabekRoman issue comment termux/proot

ZhymabekRoman
ZhymabekRoman

proot-distro alpine and xfce4

platrform

android 10, termux 0.117

Problem description

Unable to start xfce in alpine. Termux just crashes, and before that, a bunch of errors pops up ...

Steps to reproduce

pkg install proot-distro; proot-distro install alpine; proot-distro login alpine; Xvfb :1 -screen 0 1920x1080x24 & x11vnc -xkb -noxrecord -noxfixes -noxdamage -display :1 > -nopw -wait 5 -shared -permitfiletransfer -tightfilexfer -noshm & DISPLAY=:1 openbox & DISPLAY=:1 xfce4-terminal & DISPLAY=:1 startxfce4 & #4-session --display=:1

ZhymabekRoman
ZhymabekRoman
Nov
24
1 week ago
Nov
22
1 week ago
Activity icon
issue

ZhymabekRoman issue comment termux/proot-distro

ZhymabekRoman
ZhymabekRoman

[Feature]: Enable built in Desktop Environment

Feature description

xfce4 is very lite weight Desktop Environment only 200 mb size

with xfce4-goodies having all necessary plugins only having 10 mb size

with firefox browser having 70 mb size

for automatic or dialog based VNC server command click here

200 + 10 + 70 = 280 ≈ 300 mb maximum size required.

ZhymabekRoman
ZhymabekRoman

From README.md file:

All systems come in a bare-minumum variant, typically consisting of package manager, shell, coreutils, util-linux and few more. Extended functionality like shell completion or package install suggestions should be configured manually.

IMHO do not need to burden proot-distro's with third-party packages, I personally from third-party packages directly install Openbox and xterm, xfce4 not correctly works with VNC/Xorg clients, now I do not remember, If I'm not mistake the problem was the lack of support for some kind of extension by Xorg and VNC client

Nov
21
2 weeks ago
Activity icon
issue

ZhymabekRoman issue comment termux/proot-distro

ZhymabekRoman
ZhymabekRoman

[Bug]: can't update

Problem description

[email protected]:~#1 http://ports.ubuntu.com/ubuntu-ports hirsute InRelease Ign:2 http://ports.ubuntu.com/ubuntu-ports hirsute-updates InRelease Ign:3 http://ports.ubuntu.com/ubuntu-ports hirsute-security InRelease Err:4 http://ports.ubuntu.com/ubuntu-ports hirsute Release Could not open file /var/lib/apt/lists/partial/ports.ubuntu.com_ubuntu-ports_dists_hirsute_Release - open (13: Permission denied) [IP: 240.0.0.245 80] Err:5 http://ports.ubuntu.com/ubuntu-ports hirsute-updates Release Could not open file /var/lib/apt/lists/partial/ports.ubuntu.com_ubuntu-ports_dists_hirsute-updates_Release - open (13: Permission denied) [IP: 240.0.0.245 80] Err:6 http://ports.ubuntu.com/ubuntu-ports hirsute-security Release Could not open file /var/lib/apt/lists/partial/ports.ubuntu.com_ubuntu-ports_dists_hirsute-security_Release - open (13: Permission denied) [IP: 240.0.0.245 80] Reading package lists... Error! W: Download is performed unsandboxed as root as file '/var/lib/apt/lists/partial/ports.ubuntu.com_ubuntu-ports_dists_hirsute_InRelease' couldn't be accessed by user '_apt'. - pkgAcquire::Run (13: Permission denied) E: The repository 'http://ports.ubuntu.com/ubuntu-ports hirsute Release' does not have a Release file. N: Updating from such a repository can't be done securely, and is therefore disabled by default. N: See apt-secure(8) manpage for repository creation and user configuration details. E: The repository 'http://ports.ubuntu.com/ubuntu-ports hirsute-updates Release' does not have a Release file. N: Updating from such a repository can't be done securely, and is therefore disabled by default. N: See apt-secure(8) manpage for repository creation and user configuration details. E: The repository 'http://ports.ubuntu.com/ubuntu-ports hirsute-security Release' does not have a Release file. N: Updating from such a repository can't be done securely, and is therefore disabled by default. N: See apt-secure(8) manpage for repository creation and user configuration details. E: Could not create temporary file for /var/cache/apt/srcpkgcache.bin - mkstemp (13: Permission denied) E: The package lists or status file could not be parsed or opened. [email protected]:~#20211121-141828](https://user-images.githubusercontent.com/74664513/142751968-fcfebb0f-1713-412d-9060-657248b64c1b.png)

What steps will reproduce the bug?

proot-distro install ubuntu proot-distro login ubuntu apt update

What is the expected behavior?

can update

ZhymabekRoman
ZhymabekRoman
Activity icon
issue

ZhymabekRoman issue comment termux/proot-distro

ZhymabekRoman
ZhymabekRoman

[Bug]: can't update

Problem description

[email protected]:~#1 http://ports.ubuntu.com/ubuntu-ports hirsute InRelease Ign:2 http://ports.ubuntu.com/ubuntu-ports hirsute-updates InRelease Ign:3 http://ports.ubuntu.com/ubuntu-ports hirsute-security InRelease Err:4 http://ports.ubuntu.com/ubuntu-ports hirsute Release Could not open file /var/lib/apt/lists/partial/ports.ubuntu.com_ubuntu-ports_dists_hirsute_Release - open (13: Permission denied) [IP: 240.0.0.245 80] Err:5 http://ports.ubuntu.com/ubuntu-ports hirsute-updates Release Could not open file /var/lib/apt/lists/partial/ports.ubuntu.com_ubuntu-ports_dists_hirsute-updates_Release - open (13: Permission denied) [IP: 240.0.0.245 80] Err:6 http://ports.ubuntu.com/ubuntu-ports hirsute-security Release Could not open file /var/lib/apt/lists/partial/ports.ubuntu.com_ubuntu-ports_dists_hirsute-security_Release - open (13: Permission denied) [IP: 240.0.0.245 80] Reading package lists... Error! W: Download is performed unsandboxed as root as file '/var/lib/apt/lists/partial/ports.ubuntu.com_ubuntu-ports_dists_hirsute_InRelease' couldn't be accessed by user '_apt'. - pkgAcquire::Run (13: Permission denied) E: The repository 'http://ports.ubuntu.com/ubuntu-ports hirsute Release' does not have a Release file. N: Updating from such a repository can't be done securely, and is therefore disabled by default. N: See apt-secure(8) manpage for repository creation and user configuration details. E: The repository 'http://ports.ubuntu.com/ubuntu-ports hirsute-updates Release' does not have a Release file. N: Updating from such a repository can't be done securely, and is therefore disabled by default. N: See apt-secure(8) manpage for repository creation and user configuration details. E: The repository 'http://ports.ubuntu.com/ubuntu-ports hirsute-security Release' does not have a Release file. N: Updating from such a repository can't be done securely, and is therefore disabled by default. N: See apt-secure(8) manpage for repository creation and user configuration details. E: Could not create temporary file for /var/cache/apt/srcpkgcache.bin - mkstemp (13: Permission denied) E: The package lists or status file could not be parsed or opened. [email protected]:~#20211121-141828](https://user-images.githubusercontent.com/74664513/142751968-fcfebb0f-1713-412d-9060-657248b64c1b.png)

What steps will reproduce the bug?

proot-distro install ubuntu proot-distro login ubuntu apt update

What is the expected behavior?

can update

ZhymabekRoman
ZhymabekRoman

@spz2020, judging by the screenshot you are using a VPN connection, try to turn it off.

Activity icon
issue

ZhymabekRoman issue comment termux/proot-distro

ZhymabekRoman
ZhymabekRoman

[ASK]:how to use see storage file?

Feature description

I don't know how to see storage file, is there an option to see storage?

ZhymabekRoman
ZhymabekRoman

storage is a folder, not a file, and you can view the folder in the usual way:

.../git/translate $ proot-distro login ubuntu
[email protected]:~# cd /storage/
[email protected]:/storage# ls
89E9-1315  emulated  enc_emulated  self
[email protected]:/storage#
Nov
20
2 weeks ago
Activity icon
issue

ZhymabekRoman issue comment termux/proot-distro

ZhymabekRoman
ZhymabekRoman

[Bug]: Automatically Termux crashes when we use tigervnc server

Problem description

the connection closed unexpectedly this error thrown by vnc viewer

automatically get crashes app when we use tigervnc server

What steps will reproduce the bug?

tigervncserver this cammand

What is the expected behavior?

vnc server start

ZhymabekRoman
ZhymabekRoman
Activity icon
issue

ZhymabekRoman issue comment Animenosekai/translate

ZhymabekRoman
ZhymabekRoman

[add] Support Python 3.10

In the inquirer library, which is used to work CLI translatepy, there is a bug because of which on Python 3.10 it does not work. Fixed in inquirer 2.8.0. For more information see this: https://github.com/magmax/python-inquirer/pull/123

ZhymabekRoman
ZhymabekRoman

Ahh, yes, I'm sorry, I forgot that external libraries are also can be specified in setup.py

push

ZhymabekRoman push ZhymabekRoman/translate

ZhymabekRoman
ZhymabekRoman

[fix] Specify inquirer library version in setup.py

commit sha: edf44b609921ee774dd1de4754a9ea36482cae29

push time in 2 weeks ago
started
started time in 2 weeks ago
Activity icon
issue

ZhymabekRoman issue comment magmax/python-inquirer

ZhymabekRoman
ZhymabekRoman

Ignore example

It would be very nice to have a ignore example.

I have a list of four questions: two Confirm questions and two Text after each Confirm. I want to prompt the Text questions only if you answered yes to the previous. How would you do that using python-inquirer?

I've searched the whole repo and documentation and didn't find one. Could you add one please?

ZhymabekRoman
ZhymabekRoman

It would be very nice to have a ignore example.

I have a list of four questions: two Confirm questions and two Text after each Confirm. I want to prompt the Text questions only if you answered yes to the previous. How would you do that using python-inquirer?

I've searched the whole repo and documentation and didn't find one. Could you add one please?

Can you show a reproducible example?

pull request

ZhymabekRoman pull request Animenosekai/translate

ZhymabekRoman
ZhymabekRoman

[add] Support Python 3.10

In the inquirer library, which is used to work CLI translatepy, there is a bug because of which on Python 3.10 it does not work. Fixed in inquirer 2.8.0. For more information see this: https://github.com/magmax/python-inquirer/pull/123

Previous