bfeige

bfeige

Member Since 9 months ago

Experience Points
0
follower
Lessons Completed
0
follow
Best Reply Awards
1
repos

2 contributions in the last year

Pinned
⚡ Config files for my GitHub profile.
Activity
Nov
21
2 months ago
Activity icon
issue

bfeige issue comment fwestenberg/reolink_dev

bfeige
bfeige

Motion Sensors do not work - Usually Unavailable

Hi,

Can't get the sensors to operate. Connected via RLN16-410 NVR with the latest firmware 3.0.0.148. Cameras are RLC-810A and RLC-820A with the latest firmware 3.0.0.494. Have set internal URL, and enabled ONVIF on the NVR.

In the log I can see the following: Logger: reolink.subscription_manager Source: /usr/local/lib/python3.9/site-packages/reolink/subscription_manager.py:103 First occurred: 18:57:00 (126 occurrences) Last logged: 19:02:00

Subscription process ended with wrong HTTP status: 400: Bad Request

And the following: Logger: custom_components.reolink_dev.base Source: custom_components/reolink_dev/base.py:376 Integration: Reolink IP camera (documentation, issues) First occurred: 18:57:00 (42 occurrences) Last logged: 19:02:00

Host 192.168.1.248 error renewing the Reolink subscription

Occasionally, I can see some data from the sensors, but these are mostly unavailable.

What I could be missing? What additional information/log can I provide?

Thanks.

bfeige
bfeige

Have decided to move away from this integration, not the integrations fault as I'm sure they will eventually fix the AI sensors webhook subscription issue, I am moving away as the streams are 10 sec behind actual (and regualry freeze), instead am using rest (as above) for the sensors and rtsp for the streams as combining with webrtc card I can get pretty close to realtime streams that don't freeze, combining this with condition cards gives me a display that shows my cameras 4 at a time and then changes to full screen on person/vehicle motion, I setup a couple of helpers to use as triggers to change which 4 are shown at a time that way the 8 cameras I have all get shown over a time period and switch to full screen on motion, I cast this to my google hub max and use a button at bottom of screen combined with helper to switch between control dashboard view and camera view works pretty well but ocassionally drops out on the hub just need to rerun script to cast again if it does, will eventually combine all this into a tablet instead as casting to hub means I cannot send it anything else like tts without the cast dropping.

Nov
20
2 months ago
Activity icon
issue

bfeige issue comment fwestenberg/reolink_dev

bfeige
bfeige

Motion Sensors do not work - Usually Unavailable

Hi,

Can't get the sensors to operate. Connected via RLN16-410 NVR with the latest firmware 3.0.0.148. Cameras are RLC-810A and RLC-820A with the latest firmware 3.0.0.494. Have set internal URL, and enabled ONVIF on the NVR.

In the log I can see the following: Logger: reolink.subscription_manager Source: /usr/local/lib/python3.9/site-packages/reolink/subscription_manager.py:103 First occurred: 18:57:00 (126 occurrences) Last logged: 19:02:00

Subscription process ended with wrong HTTP status: 400: Bad Request

And the following: Logger: custom_components.reolink_dev.base Source: custom_components/reolink_dev/base.py:376 Integration: Reolink IP camera (documentation, issues) First occurred: 18:57:00 (42 occurrences) Last logged: 19:02:00

Host 192.168.1.248 error renewing the Reolink subscription

Occasionally, I can see some data from the sensors, but these are mostly unavailable.

What I could be missing? What additional information/log can I provide?

Thanks.

bfeige
bfeige

check the NVR Hardware version (cog, system,info) and confirm your NVR hardware version support access to the AI sensors, H3MB18 may need Firmware upgrade N2MB02 & N3MB01 support it but H3MB02, H3MB16 do not. basically any that have the new interface.

Nov
15
2 months ago
Activity icon
issue

bfeige issue comment fwestenberg/reolink_dev

bfeige
bfeige

Motion Sensors do not work - Usually Unavailable

Hi,

Can't get the sensors to operate. Connected via RLN16-410 NVR with the latest firmware 3.0.0.148. Cameras are RLC-810A and RLC-820A with the latest firmware 3.0.0.494. Have set internal URL, and enabled ONVIF on the NVR.

In the log I can see the following: Logger: reolink.subscription_manager Source: /usr/local/lib/python3.9/site-packages/reolink/subscription_manager.py:103 First occurred: 18:57:00 (126 occurrences) Last logged: 19:02:00

Subscription process ended with wrong HTTP status: 400: Bad Request

And the following: Logger: custom_components.reolink_dev.base Source: custom_components/reolink_dev/base.py:376 Integration: Reolink IP camera (documentation, issues) First occurred: 18:57:00 (42 occurrences) Last logged: 19:02:00

Host 192.168.1.248 error renewing the Reolink subscription

Occasionally, I can see some data from the sensors, but these are mostly unavailable.

What I could be missing? What additional information/log can I provide?

Thanks.

bfeige
bfeige

No problems I am using the following workaround in my configuration.yaml

binary_sensor:

  • platform: rest resource: http://(NVR IP)/api.cgi?cmd=GetAiState&channel=00&user=(my login)&password=(my password) name: Motion_(camera position)_person scan_interval: 2 value_template: "{{ value_json[0].value.people.alarm_state }}" device_class: motion

replace people with vehicle/pet for the others, as I'm using via the NVR then I need to specify channel this is equal to the NVR channel -1, just need to duplicate for each channel and AI being used.

Nov
8
2 months ago
Activity icon
issue

bfeige issue comment fwestenberg/reolink_dev

bfeige
bfeige

Motion Sensors do not work - Usually Unavailable

Hi,

Can't get the sensors to operate. Connected via RLN16-410 NVR with the latest firmware 3.0.0.148. Cameras are RLC-810A and RLC-820A with the latest firmware 3.0.0.494. Have set internal URL, and enabled ONVIF on the NVR.

In the log I can see the following: Logger: reolink.subscription_manager Source: /usr/local/lib/python3.9/site-packages/reolink/subscription_manager.py:103 First occurred: 18:57:00 (126 occurrences) Last logged: 19:02:00

Subscription process ended with wrong HTTP status: 400: Bad Request

And the following: Logger: custom_components.reolink_dev.base Source: custom_components/reolink_dev/base.py:376 Integration: Reolink IP camera (documentation, issues) First occurred: 18:57:00 (42 occurrences) Last logged: 19:02:00

Host 192.168.1.248 error renewing the Reolink subscription

Occasionally, I can see some data from the sensors, but these are mostly unavailable.

What I could be missing? What additional information/log can I provide?

Thanks.

bfeige
bfeige

Upgraded to version 0.36 (was on Master), now have lost my AI and Motion Sensor States all together all saying "Unavailable", with previous master I was getting "off" most of the time but not "Unavailable", after upgrading I got the folling log entries

Subscription process ended with wrong HTTP status: 400: Bad Request 7:52:56 PM – (WARNING) /usr/local/lib/python3.9/site-packages/reolink/subscription_manager.py - message first occurred at 7:43:54 PM and shows up 120 times

Host 10.1.1.211 error renewing the Reolink subscription 7:52:56 PM – (ERROR) Reolink IP camera (custom integration) - message first occurred at 7:43:54 PM and shows up 40 times

Host 10.1.1.211 subscription failed to its webhook, base object state will be set to NotAvailable 7:43:54 PM – (ERROR) Reolink IP camera (custom integration)

Port 80 is used, USE_HTTPS set back to False 7:43:53 PM – (WARNING) Reolink IP camera (custom integration) - message first occurred at 7:43:53 PM and shows up 3 times

I changed the connection on one of the cameras to use 443, however this didn't make any difference to the Motion states

Activity icon
issue

bfeige issue comment fwestenberg/reolink_dev

bfeige
bfeige

Motion Sensors do not work - Usually Unavailable

Hi,

Can't get the sensors to operate. Connected via RLN16-410 NVR with the latest firmware 3.0.0.148. Cameras are RLC-810A and RLC-820A with the latest firmware 3.0.0.494. Have set internal URL, and enabled ONVIF on the NVR.

In the log I can see the following: Logger: reolink.subscription_manager Source: /usr/local/lib/python3.9/site-packages/reolink/subscription_manager.py:103 First occurred: 18:57:00 (126 occurrences) Last logged: 19:02:00

Subscription process ended with wrong HTTP status: 400: Bad Request

And the following: Logger: custom_components.reolink_dev.base Source: custom_components/reolink_dev/base.py:376 Integration: Reolink IP camera (documentation, issues) First occurred: 18:57:00 (42 occurrences) Last logged: 19:02:00

Host 192.168.1.248 error renewing the Reolink subscription

Occasionally, I can see some data from the sensors, but these are mostly unavailable.

What I could be missing? What additional information/log can I provide?

Thanks.

bfeige
bfeige

As a workaround I used rest to get states i.e

binary_sensor:

  • platform: rest resource: http:///api.cgi?cmd=GetMdState&channel=<channel cam is on -1>&user=&password= name: scan_interval: 2 value_template: "{{ value_json[0].value.state }}" device_class: motion

This works fine for Motion haven't been able to find any AI ones being exposed Note: channel id is same channel cam is on -1.

Activity icon
issue

bfeige issue comment fwestenberg/reolink_dev

bfeige
bfeige

Motion Sensors do not work - Usually Unavailable

Hi,

Can't get the sensors to operate. Connected via RLN16-410 NVR with the latest firmware 3.0.0.148. Cameras are RLC-810A and RLC-820A with the latest firmware 3.0.0.494. Have set internal URL, and enabled ONVIF on the NVR.

In the log I can see the following: Logger: reolink.subscription_manager Source: /usr/local/lib/python3.9/site-packages/reolink/subscription_manager.py:103 First occurred: 18:57:00 (126 occurrences) Last logged: 19:02:00

Subscription process ended with wrong HTTP status: 400: Bad Request

And the following: Logger: custom_components.reolink_dev.base Source: custom_components/reolink_dev/base.py:376 Integration: Reolink IP camera (documentation, issues) First occurred: 18:57:00 (42 occurrences) Last logged: 19:02:00

Host 192.168.1.248 error renewing the Reolink subscription

Occasionally, I can see some data from the sensors, but these are mostly unavailable.

What I could be missing? What additional information/log can I provide?

Thanks.

bfeige
bfeige

I can find no way to creat a Super Admin, it looks like only the built in default account has that

Activity icon
issue

bfeige issue comment fwestenberg/reolink_dev

bfeige
bfeige

Motion Sensors do not work - Usually Unavailable

Hi,

Can't get the sensors to operate. Connected via RLN16-410 NVR with the latest firmware 3.0.0.148. Cameras are RLC-810A and RLC-820A with the latest firmware 3.0.0.494. Have set internal URL, and enabled ONVIF on the NVR.

In the log I can see the following: Logger: reolink.subscription_manager Source: /usr/local/lib/python3.9/site-packages/reolink/subscription_manager.py:103 First occurred: 18:57:00 (126 occurrences) Last logged: 19:02:00

Subscription process ended with wrong HTTP status: 400: Bad Request

And the following: Logger: custom_components.reolink_dev.base Source: custom_components/reolink_dev/base.py:376 Integration: Reolink IP camera (documentation, issues) First occurred: 18:57:00 (42 occurrences) Last logged: 19:02:00

Host 192.168.1.248 error renewing the Reolink subscription

Occasionally, I can see some data from the sensors, but these are mostly unavailable.

What I could be missing? What additional information/log can I provide?

Thanks.

bfeige
bfeige

Have tried with General Account and a created Admin neither of these work either, only log entry is "User test has authorisation level guest. Only admin users can change camera settings! Switches will not work.", test is the general user

Activity icon
issue

bfeige issue comment fwestenberg/reolink_dev

bfeige
bfeige

Motion Sensors do not work - Usually Unavailable

Hi,

Can't get the sensors to operate. Connected via RLN16-410 NVR with the latest firmware 3.0.0.148. Cameras are RLC-810A and RLC-820A with the latest firmware 3.0.0.494. Have set internal URL, and enabled ONVIF on the NVR.

In the log I can see the following: Logger: reolink.subscription_manager Source: /usr/local/lib/python3.9/site-packages/reolink/subscription_manager.py:103 First occurred: 18:57:00 (126 occurrences) Last logged: 19:02:00

Subscription process ended with wrong HTTP status: 400: Bad Request

And the following: Logger: custom_components.reolink_dev.base Source: custom_components/reolink_dev/base.py:376 Integration: Reolink IP camera (documentation, issues) First occurred: 18:57:00 (42 occurrences) Last logged: 19:02:00

Host 192.168.1.248 error renewing the Reolink subscription

Occasionally, I can see some data from the sensors, but these are mostly unavailable.

What I could be missing? What additional information/log can I provide?

Thanks.

bfeige
bfeige

I haven't tried using another login, using admin default but will do, I was able to use Rest to extract motion states

Nov
2
2 months ago
Activity icon
issue

bfeige issue comment fwestenberg/reolink_dev

bfeige
bfeige

Motion Sensors do not work - Usually Unavailable

Hi,

Can't get the sensors to operate. Connected via RLN16-410 NVR with the latest firmware 3.0.0.148. Cameras are RLC-810A and RLC-820A with the latest firmware 3.0.0.494. Have set internal URL, and enabled ONVIF on the NVR.

In the log I can see the following: Logger: reolink.subscription_manager Source: /usr/local/lib/python3.9/site-packages/reolink/subscription_manager.py:103 First occurred: 18:57:00 (126 occurrences) Last logged: 19:02:00

Subscription process ended with wrong HTTP status: 400: Bad Request

And the following: Logger: custom_components.reolink_dev.base Source: custom_components/reolink_dev/base.py:376 Integration: Reolink IP camera (documentation, issues) First occurred: 18:57:00 (42 occurrences) Last logged: 19:02:00

Host 192.168.1.248 error renewing the Reolink subscription

Occasionally, I can see some data from the sensors, but these are mostly unavailable.

What I could be missing? What additional information/log can I provide?

Thanks.

bfeige
bfeige

I have same model NVR with 810A cameras, was getting same errors as above when using version 0.34 and 0.35, switched out to master version and picked the AI sensors, now sensors are reporting clear all the time even when there is motion, am getting push notifications from NVR, no errors in home assistant log, the person sensors stay constant clear, the actual main motion sensor will sometimes register motion but not reliably