eromoe

eromoe

Member Since 8 years ago

Experience Points
6
follower
Lessons Completed
6
follow
Lessons Completed
285
stars
Best Reply Awards
100
repos

109 contributions in the last year

Pinned
⚡ Base ubuntu 14.04(include python2.7) docker image with China Package Source.
⚡ 签到
⚡ A Powerful Spider(Web Crawler) System in Python.
⚡ Download images from Pixiv and more!
Activity
Sep
22
3 weeks ago
Activity icon
issue

eromoe issue elyra-ai/elyra

eromoe
eromoe

Please add CDN or Bundle external requirement in elyra

I got super slow jupyter lab startup due to Failed to connect to URL for component . Why not bundle these dependency inside elyra by submodule or something else ?

[I 2021-09-22 20:13:59.561 ServerApp] nbclassic | extension was successfully loaded.
[I 2021-09-22 20:13:59.561 ElyraApp] Config {'ServerApp': {'jpserver_extensions': <LazyConfigValue value={'jupyterlab': True, 'elyra': True, 'jupyter_lsp': True, 'jupyter_resource_usage': True, 'jupyter_server_mathjax': True, 'jupyterlab_git': True, 'nbclassic': True, 'nbdime': True}>}}
[W 2021-09-22 20:14:00.770 ServerApp] Failed to connect to URL for component: https://raw.githubusercontent.com/apache/airflow/1.10.15/airflow/operators/bash_operator.py: ('Connection aborted.', ConnectionResetError(10054, '远程主机强迫关闭了一个现有的连接。', None, 10054, None))
[W 2021-09-22 20:14:00.858 ServerApp] Failed to connect to URL for component: https://raw.githubusercontent.com/apache/airflow/1.10.15/airflow/operators/email_operator.py: ('Connection aborted.', ConnectionResetError(10054, '远程主机强迫关 闭了一个现有的连接。', None, 10054, None))
[W 2021-09-22 20:14:22.602 ServerApp] Failed to connect to URL for component: https://raw.githubusercontent.com/apache/airflow/1.10.15/airflow/operators/http_operator.py: ('Connection aborted.', TimeoutError(10060, '由于连接方在一段时间后没有正确答复或连接的主机没有反应,连接尝试失败。', None, 10060, None))
[W 2021-09-22 20:15:04.800 ServerApp] Failed to connect to URL for component: https://raw.githubusercontent.com/apache/airflow/1.10.15/airflow/contrib/operators/spark_sql_operator.py: ('Connection aborted.', ConnectionResetError(10054, '远 程主机强迫关闭了一个现有的连接。', None, 10054, None))
[W 2021-09-22 20:15:25.939 ServerApp] Failed to connect to URL for component: https://raw.githubusercontent.com/apache/airflow/1.10.15/airflow/contrib/operators/spark_submit_operator.py: ('Connection aborted.', ConnectionResetError(10054, '远程主机强迫关闭了一个现有的连接。', None, 10054, None))
Sep
18
4 weeks ago
Activity icon
issue

eromoe issue tp4a/teleport

eromoe
eromoe

如何用 wsl2 ?

或者msys2 之类的shell

Sep
15
1 month ago
Activity icon
issue

eromoe issue comment elyra-ai/elyra

eromoe
eromoe

Can't run introduction-to-generic-pipelines, got invalidPipeline error

Error message

{
  "severity": 1,
  "source": "Elyra Pipeline Validation Service",
  "type": "invalidPipeline",
  "message": "Primary pipeline version field has an invalid value.",
  "data": {
    "supported_version": 4,
    "detected_version": 5
  }
}
eromoe
eromoe

@ptitzler Yes , elyra is latest 3.1.0 .
PS: this error doesn't show in elyra/elyra:dev docker image

Activity icon
issue

eromoe issue elyra-ai/elyra

eromoe
eromoe

Can't run introduction-to-generic-pipelines, got invalidPipeline error

Error message

{
  "severity": 1,
  "source": "Elyra Pipeline Validation Service",
  "type": "invalidPipeline",
  "message": "Primary pipeline version field has an invalid value.",
  "data": {
    "supported_version": 4,
    "detected_version": 5
  }
}
Activity icon
issue

eromoe issue elyra-ai/examples

eromoe
eromoe

Can't run introduction-to-generic-pipelines, got invalidPipeline error

Error message

{
  "severity": 1,
  "source": "Elyra Pipeline Validation Service",
  "type": "invalidPipeline",
  "message": "Primary pipeline version field has an invalid value.",
  "data": {
    "supported_version": 4,
    "detected_version": 5
  }
}
Sep
7
1 month ago
Activity icon
issue

eromoe issue comment microsoft/vscode-remote-release

eromoe
eromoe

Enable custom shell initialization script on the remote

The system where I would use the Remote SSH feature has a quite "vintage" tool setup by default, which causes installation of the extension to fail. By modifying my .bashrc I am able to work around this with generous use of module add, but now my whole environment is "non-standard", and build tools ding me for this, even if I'm not using Code. I'm sure that at some point I will spend days looking for a bug caused by me swapping out the core GNU tooling for a different version.

I suggest adding the possibility to specify a script that is sourced on the remote before executing the installation and launching the extension server. It doesn't have to be a setting, just a script with a known name. This would put the remote tools on equal footing with the IDE itself, where i am able to run code inside a custom environment by sourcing a setup script first, without having to "pollute" my .bashrc.

This request might be slightly related to #83.

eromoe
eromoe

Anyway to su another user after ssh ?

Aug
28
1 month ago
started
started time in 1 month ago
Aug
23
1 month ago
Activity icon
issue

eromoe issue comment microsoft/WSL

eromoe
eromoe

SSH connections hanging from WSL2

Current Version 10.0.19025.1

I have this weird issue where I can no longer use SSH connections to remote servers from WSL2. I remember that it was working ok in early builds but I am not sure at which point it started to fail.

Any idea on how to resolve this would be appreciated.

What happens

When connected to a remote server, SSH connection hangs after a very short time. I am sometimes able to type a few letters but then it hangs and have to close WSL. It does this with every SSH connections to every server.

For instance, on the following screenshot, you can see that I was able to type a few numbers but the connection froze at the last "1".

image

Probably related, SSH git cloning is not working either. It starts receiving objects but stops shortly after. I have to CTRL-C to stop. Here's an example hanging at 46%.

> GIT_SSH_COMMAND="ssh -vvv" git clone --verbose [email protected]:microsoft/dotnet.git

... image

In WSL1, everything works smoothly and have no issues. It's only in WSL2 that this happens.

Note that git cloning through HTTPS works fine as well.

Just let me know if there is additional trace I can run to help since I know this is probably going to be hard to repro.

eromoe
eromoe

@izderadicka This MTU settings make all ssh connections super slow. I don't know much about network technical, do you have any suggestion ?

Aug
22
1 month ago
Activity icon
issue

eromoe issue comment jupyter/docker-stacks

eromoe
eromoe

How do I add jar while using scala shell ?

I know it only need add env in pyspark , but there is no introduction tell how to add jar in scala

eromoe
eromoe

Nope, it is here . Here is no document tell how to add jar while using jupyter/all-spark-notebook image . It is easy to add jar when you directly run spark-shell which some parameters.

Aug
21
1 month ago
started
started time in 1 month ago
Aug
20
1 month ago
Activity icon
issue

eromoe issue comment Fndroid/clash_for_windows_pkg

eromoe
eromoe

Mac Apple Silicon can't start clash for windows.

信息

  • 已经从issue搜索过类似问题,并未发现重复
  • 已经阅读过文档相关问题,并未找到解决办法
  • 已经尝试更新到最新版本,问题依旧存在
  • 软件从本仓库下载,并非任何非官方版本(包括任何替换软件目录文件操作)

系统

//: #1 Apple SILICON

描述

//: # Can't start clash.

复现

  1. download arm64 dmg file.
  2. move clash to applications
  3. click clash for windows.
  4. prompt the error as the follow picture.

both the 17.0. and 17.1 can be reproduced. image

eromoe
eromoe

@donald-ning 想问一下为什么一定要通过命令安装?

Activity icon
issue

eromoe issue comment Dreamacro/clash

eromoe
eromoe

[Bug][0904部分解决] Vmess TCP模式 http带path混淆不工作 [目前直连可以用,但是不可用于vless回落]

V2ray vless支持TCP http path混淆分流,于是进行测试了,很简单在v2ray tcp上加上

                        "header": {
                            "type": "http",
                            "request": {
                                "path": ["/vmesstcp"]
                                                }

然后在v2rayng客户端上加上path 为/vmesstcp就可以工作了,因此期望在clash上也可以很方便的工作。但是试了所有组合都不行。根据#156应该是支持这种混淆方式的。

  type: vmess
  server: myazure.dom
  port: 443
  uuid: 070896a7-xxxx-4cd6-a243-db052bc0uuid
  alterId: 3
  cipher: none
  tls: true
  skip-cert-verify: true
  network: tcp #改成http也不行,我不确认这儿应该选什么
  http-opts:
   path:
     - '/vmesstcp'

加上method headers也不行,甚至我把v2rayng的配置导出来,然后写入clash,能运行,但是仍然不能用。

  type: vmess
  server: myazure.dom
  port: 443
  uuid: 070896a7-xxxx-4cd6-a243-db052bc0uuid
  alterId: 3
  cipher: none
  tls: true
  skip-cert-verify: true
  network: tcp #改成http也不行,我不确认这儿应该选什么
  http-opts:
   version: "1.1"
   method: "GET"
   path:
     - '/vmesstcp'
   headers:
    Connection:
      - keep-alive
    Host:
      -  myazure.dom
    Pragma:
      - no-cache
    User-Agent:
      - "Mozilla/5.0 (Windows NT 10.0; WOW64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/55.0.2883.75 Safari/537.36"
    Accept-Encoding: 
      - "gzip, deflate"
eromoe
eromoe

network: tcp 改成 network: http 才可用。真是要吐槽

和v2ray 官方文档不一致,和 v2ray gui 客户端 也不一致 一般是: "network": "tcp", "headerType": "http",

结果clash 变成了 network: http 没有简明的文档解释 。 一般直接有一个配置页面解释清楚具体配置,不解释的话就和官方一致,怎么会这么混乱??

Activity icon
issue

eromoe issue comment Dreamacro/clash

eromoe
eromoe

[Bug][0904部分解决] Vmess TCP模式 http带path混淆不工作 [目前直连可以用,但是不可用于vless回落]

V2ray vless支持TCP http path混淆分流,于是进行测试了,很简单在v2ray tcp上加上

                        "header": {
                            "type": "http",
                            "request": {
                                "path": ["/vmesstcp"]
                                                }

然后在v2rayng客户端上加上path 为/vmesstcp就可以工作了,因此期望在clash上也可以很方便的工作。但是试了所有组合都不行。根据#156应该是支持这种混淆方式的。

  type: vmess
  server: myazure.dom
  port: 443
  uuid: 070896a7-xxxx-4cd6-a243-db052bc0uuid
  alterId: 3
  cipher: none
  tls: true
  skip-cert-verify: true
  network: tcp #改成http也不行,我不确认这儿应该选什么
  http-opts:
   path:
     - '/vmesstcp'

加上method headers也不行,甚至我把v2rayng的配置导出来,然后写入clash,能运行,但是仍然不能用。

  type: vmess
  server: myazure.dom
  port: 443
  uuid: 070896a7-xxxx-4cd6-a243-db052bc0uuid
  alterId: 3
  cipher: none
  tls: true
  skip-cert-verify: true
  network: tcp #改成http也不行,我不确认这儿应该选什么
  http-opts:
   version: "1.1"
   method: "GET"
   path:
     - '/vmesstcp'
   headers:
    Connection:
      - keep-alive
    Host:
      -  myazure.dom
    Pragma:
      - no-cache
    User-Agent:
      - "Mozilla/5.0 (Windows NT 10.0; WOW64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/55.0.2883.75 Safari/537.36"
    Accept-Encoding: 
      - "gzip, deflate"
eromoe
eromoe

域名到期换成 tcp+http 就无法链接,clash的配置文档太不完善了,ws+tls 的配置也和v2ray 官方不一样。

Aug
19
1 month ago
Activity icon
issue

eromoe issue pepa65/tldr-bash-client

eromoe
eromoe

tldr page for command tar not found

Seems pages structure wrong ?

find: ‘/home/xxx/.local/share/tldr/pages.c./common/tar.md’: No such file or directory

 Could not download https://raw.githubusercontent.com/tldr-pages/tldr/master/pages.c./common/tar.md

 tldr page for command tar not found

 Contribute new pages at: https://github.com/tldr-pages/tldr
Aug
17
1 month ago
Activity icon
fork

eromoe forked titicaca/spark-gbtlr

⚡ Hybrid model of Gradient Boosting Trees and Logistic Regression (GBDT+LR) on Spark
eromoe Apache License 2.0 Updated
fork time in 1 month ago
Activity icon
fork

eromoe forked liuqitoday/qinglong-auto-sharecodes

fork time in 1 month ago
Aug
16
2 months ago
Activity icon
issue

eromoe issue jupyter/docker-stacks

eromoe
eromoe

How do I add jar while using scala shell ?

I know it only need add env in pyspark , but there is no introduction tell how to add jar in scala

Jul
19
2 months ago
started
started time in 2 months ago