louis77

louis77

Entrepreneur, developer and FOSS enthusiast.

Member Since 9 years ago

@openbooking, Switzerland

Experience Points
14
follower
Lessons Completed
8
follow
Lessons Completed
59
stars
Best Reply Awards
13
repos

1433 contributions in the last year

Pinned
⚡ GNU/Linux app to discover and play internet radio stations
⚡ :envelope: Teaching an Old Dog New Tricks -- IRC: #neomutt on irc.libera.chat
Activity
Nov
24
4 days ago
Activity icon
issue

louis77 issue comment microsoft/azuredatastudio-postgresql

louis77
louis77

PostgreSQL extension can't script Create Table

Hi I'm using Azure Data Studio Insiders with PostgreSQL extension, when I try to generate a script using: script as create option menu, I obtain the following message in pgSQLToolsService console.

[Error - 10:14:26 AM] Request scripting/script failed. Message: column rel.relhasoids does not exist LINE 8: pg_get_userbyid(rel.relowner) AS relowner, rel.relhasoids, ^

Code: 0 [object Object]

Here are the details of Azure Data Studio that i'm using Version: 1.19.0-insider (user setup) Commit: b922fc7d7a769a7ce1aa5f95aa48c4951c233925 Date: 2020-06-16T05:24:47.444Z VS Code: 1.46.0 Electron: 7.3.0 Chrome: 78.0.3904.130 Node.js: 12.8.1 V8: 7.8.279.23-electron.0 OS: Windows_NT x64 10.0.18363

louis77
louis77

Having this error to for scripting tables and materialized views. This error is open for almost 1.5 years now. Would be great if there will be a fix released soon!

Nov
15
1 week ago
started
started time in 1 week ago
Nov
11
2 weeks ago
started
started time in 2 weeks ago
Nov
9
2 weeks ago
Activity icon
issue

louis77 issue comment louis77/tuner

louis77
louis77

Tuner and Linux chrooted environments on Android devices

It would be very interesting to build yours player also for Aarch64 Bit distributions executed by using Proot. There are currently two main projects for such tasks. Termux and Userland. Both of those environments are using Proot which executed Linux apps by using Btrace and system calls monitoring and changing them in real time. X11 apps can be used thanks to VNC clients for Android such as Bvnc Pro. I will send build logs and error message after executing The player.

louis77
louis77

Can you try to find out the permission for your directory /home/janusz/.local/share/ and post them here?

Oct
23
1 month ago
Activity icon
issue

louis77 issue louis77/tuner

louis77
louis77

Please how to start yours excellent radio player manually

I have built your wonderful radio player app. But how to start it manually please? Command tuner do not work. Which is The compiled executable binary name please?

Activity icon
issue

louis77 issue comment louis77/tuner

louis77
louis77

Please how to start yours excellent radio player manually

I have built your wonderful radio player app. But how to start it manually please? Command tuner do not work. Which is The compiled executable binary name please?

louis77
louis77

Sure, you can open a separate issue and paste all your messages. I will certainly look at it!

Oct
22
1 month ago
Activity icon
issue

louis77 issue orlov-vo/parcel-transformer-svelte

louis77
louis77

Assets not resolved

Hi there I'm using Parcel with the following config:

{
  "extends": ["@parcel/config-default"],
  "transformers": {
    "*.svelte": ["parcel-transformer-svelte"],
    "*.hbs": ["@anikin/parcel-transformer-handlebars-precompile"]
  }
}

It looks like the assets used in Svelte files (pngs etc.) are not resolved and bundled like the assets used in plain html/js files. Is there any configuration that needs to be done to accomplish this?

Activity icon
issue

louis77 issue parcel-bundler/parcel

louis77
louis77

Raw bundles must only contain one asset

🐛 bug report

Whatever I do, I always get the following error message when running parcel:

Server running at http://localhost:1234
× Build failed.

@parcel/packager-raw: Raw bundles must only contain one asset

  AssertionError [ERR_ASSERTION]: Raw bundles must only contain one asset
  at Object.package (v1\node_modules\@parcel\packager-raw\lib\RawPackager.js:40:23)
  at PackagerRunner.package
  (\node_modules\parcel\node_modules\@parcel\core\lib\PackagerRunner.js:294:27)
  at processTicksAndRejections (internal/process/task_queues.js:95:5)
  at async PackagerRunner.getBundleResult
  (\node_modules\parcel\node_modules\@parcel\core\lib\PackagerRunner.js:253:20)
  at async PackagerRunner.getBundleInfo
  (\node_modules\parcel\node_modules\@parcel\core\lib\PackagerRunner.js:239:9)
  at async PackagerRunner.run
  (\node_modules\parcel\node_modules\@parcel\core\lib\PackagerRunner.js:160:183)
  at async Child.handleRequest (\node_modules\parcel\node_modules\@parcel\workers\lib\child.js:217:9)

I've dumped the asset variable to the console and get a list of assets:

[
Asset(v1\node_modules\leaflet\dist\images\layers-2x.png)
]
[ Asset(v1\css\images\ui-icons_555_256x240.png) ]
[ Asset(v1\css\images\ui-icons_fff_256x240.png) ]
[
Asset(v1\assets\fonts\glyphicons-halflings-regular.eot)
]
[
Asset(v1\assets\fonts\glyphicons-halflings-regular.woff)
]
[ Asset(v1\assets\fonts\glyphicons-regular.eot) ]
[ Asset(v1\assets\fonts\glyphicons-regular.woff) ]
[
Asset(v1\node_modules\leaflet\dist\images\layers.png)
]
[
Asset(v1\node_modules\leaflet\dist\images\marker-icon.png)
]
[ Asset(v1\css\images\ui-icons_ffffff_256x240.png) ]
[ Asset(v1\css\images\ui-icons_cc0000_256x240.png) ]

🎛 Configuration (.babelrc, package.json, cli command)

{
  "extends": ["@parcel/config-default"],
  "transformers": {
    "*.svelte": ["parcel-transformer-svelte"],
    "*.hbs": ["@andreyvolokitin/parcel-transformer-handlebars"]
  }
}

🌍 Your Environment

Software Version(s)
Parcel 2.0.0
Node v14.18.0
npm 6.14.15
Operating System Win 11
Activity icon
issue

louis77 issue comment parcel-bundler/parcel

louis77
louis77

Raw bundles must only contain one asset

🐛 bug report

Whatever I do, I always get the following error message when running parcel:

Server running at http://localhost:1234
× Build failed.

@parcel/packager-raw: Raw bundles must only contain one asset

  AssertionError [ERR_ASSERTION]: Raw bundles must only contain one asset
  at Object.package (v1\node_modules\@parcel\packager-raw\lib\RawPackager.js:40:23)
  at PackagerRunner.package
  (\node_modules\parcel\node_modules\@parcel\core\lib\PackagerRunner.js:294:27)
  at processTicksAndRejections (internal/process/task_queues.js:95:5)
  at async PackagerRunner.getBundleResult
  (\node_modules\parcel\node_modules\@parcel\core\lib\PackagerRunner.js:253:20)
  at async PackagerRunner.getBundleInfo
  (\node_modules\parcel\node_modules\@parcel\core\lib\PackagerRunner.js:239:9)
  at async PackagerRunner.run
  (\node_modules\parcel\node_modules\@parcel\core\lib\PackagerRunner.js:160:183)
  at async Child.handleRequest (\node_modules\parcel\node_modules\@parcel\workers\lib\child.js:217:9)

I've dumped the asset variable to the console and get a list of assets:

[
Asset(v1\node_modules\leaflet\dist\images\layers-2x.png)
]
[ Asset(v1\css\images\ui-icons_555_256x240.png) ]
[ Asset(v1\css\images\ui-icons_fff_256x240.png) ]
[
Asset(v1\assets\fonts\glyphicons-halflings-regular.eot)
]
[
Asset(v1\assets\fonts\glyphicons-halflings-regular.woff)
]
[ Asset(v1\assets\fonts\glyphicons-regular.eot) ]
[ Asset(v1\assets\fonts\glyphicons-regular.woff) ]
[
Asset(v1\node_modules\leaflet\dist\images\layers.png)
]
[
Asset(v1\node_modules\leaflet\dist\images\marker-icon.png)
]
[ Asset(v1\css\images\ui-icons_ffffff_256x240.png) ]
[ Asset(v1\css\images\ui-icons_cc0000_256x240.png) ]

🎛 Configuration (.babelrc, package.json, cli command)

{
  "extends": ["@parcel/config-default"],
  "transformers": {
    "*.svelte": ["parcel-transformer-svelte"],
    "*.hbs": ["@andreyvolokitin/parcel-transformer-handlebars"]
  }
}

🌍 Your Environment

Software Version(s)
Parcel 2.0.0
Node v14.18.0
npm 6.14.15
Operating System Win 11
louis77
louis77

For the record, it was an issue with the handlebars transformer @andreyvolokitin/parcel-transformer-handlebars. Instead, I use this now which works perfectly:

@anikin/parcel-transformer-handlebars-precompile

Closing the issue, not related to parcel-bundler.

Activity icon
issue

louis77 issue comment parcel-bundler/parcel

louis77
louis77

Raw bundles must only contain one asset

🐛 bug report

Whatever I do, I always get the following error message when running parcel:

Server running at http://localhost:1234
× Build failed.

@parcel/packager-raw: Raw bundles must only contain one asset

  AssertionError [ERR_ASSERTION]: Raw bundles must only contain one asset
  at Object.package (v1\node_modules\@parcel\packager-raw\lib\RawPackager.js:40:23)
  at PackagerRunner.package
  (\node_modules\parcel\node_modules\@parcel\core\lib\PackagerRunner.js:294:27)
  at processTicksAndRejections (internal/process/task_queues.js:95:5)
  at async PackagerRunner.getBundleResult
  (\node_modules\parcel\node_modules\@parcel\core\lib\PackagerRunner.js:253:20)
  at async PackagerRunner.getBundleInfo
  (\node_modules\parcel\node_modules\@parcel\core\lib\PackagerRunner.js:239:9)
  at async PackagerRunner.run
  (\node_modules\parcel\node_modules\@parcel\core\lib\PackagerRunner.js:160:183)
  at async Child.handleRequest (\node_modules\parcel\node_modules\@parcel\workers\lib\child.js:217:9)

I've dumped the asset variable to the console and get a list of assets:

[
Asset(v1\node_modules\leaflet\dist\images\layers-2x.png)
]
[ Asset(v1\css\images\ui-icons_555_256x240.png) ]
[ Asset(v1\css\images\ui-icons_fff_256x240.png) ]
[
Asset(v1\assets\fonts\glyphicons-halflings-regular.eot)
]
[
Asset(v1\assets\fonts\glyphicons-halflings-regular.woff)
]
[ Asset(v1\assets\fonts\glyphicons-regular.eot) ]
[ Asset(v1\assets\fonts\glyphicons-regular.woff) ]
[
Asset(v1\node_modules\leaflet\dist\images\layers.png)
]
[
Asset(v1\node_modules\leaflet\dist\images\marker-icon.png)
]
[ Asset(v1\css\images\ui-icons_ffffff_256x240.png) ]
[ Asset(v1\css\images\ui-icons_cc0000_256x240.png) ]

🎛 Configuration (.babelrc, package.json, cli command)

{
  "extends": ["@parcel/config-default"],
  "transformers": {
    "*.svelte": ["parcel-transformer-svelte"],
    "*.hbs": ["@andreyvolokitin/parcel-transformer-handlebars"]
  }
}

🌍 Your Environment

Software Version(s)
Parcel 2.0.0
Node v14.18.0
npm 6.14.15
Operating System Win 11
louis77
louis77

Ok, so quick update on this issue. It turns out that the console output from the assets is actually from those wo worked. console.log didn't flush output (console.log is async on windows). So I put the assets into the assert error message and got this:

@parcel/packager-raw: Raw bundles must only contain one asset (4 [
Asset(v1\templates\filter_feature.hbs),
Asset(v1\templates\filter_quality.hbs),
Asset(-v1\templates\filter_type.hbs),
Asset(v1\templates\filter_tags.hbs)
])

So for some reasons the handlebars templates appear in the packager-raw process. I'm new to Parcel so I assume it must have something to do with the @andreyvolokitin/parcel-transformer-handlebars transformer.

Oct
21
1 month ago
Activity icon
issue

louis77 issue parcel-bundler/parcel

louis77
louis77

Raw bundles must only contain one asset

🐛 bug report

Whatever I do, I always get the following error message when running parcel:

Server running at http://localhost:1234
× Build failed.

@parcel/packager-raw: Raw bundles must only contain one asset

  AssertionError [ERR_ASSERTION]: Raw bundles must only contain one asset
  at Object.package (v1\node_modules\@parcel\packager-raw\lib\RawPackager.js:40:23)
  at PackagerRunner.package
  (\node_modules\parcel\node_modules\@parcel\core\lib\PackagerRunner.js:294:27)
  at processTicksAndRejections (internal/process/task_queues.js:95:5)
  at async PackagerRunner.getBundleResult
  (\node_modules\parcel\node_modules\@parcel\core\lib\PackagerRunner.js:253:20)
  at async PackagerRunner.getBundleInfo
  (\node_modules\parcel\node_modules\@parcel\core\lib\PackagerRunner.js:239:9)
  at async PackagerRunner.run
  (\node_modules\parcel\node_modules\@parcel\core\lib\PackagerRunner.js:160:183)
  at async Child.handleRequest (\node_modules\parcel\node_modules\@parcel\workers\lib\child.js:217:9)

I've dumped the asset variable to the console and get a list of assets:

[
Asset(v1\node_modules\leaflet\dist\images\layers-2x.png)
]
[ Asset(v1\css\images\ui-icons_555_256x240.png) ]
[ Asset(v1\css\images\ui-icons_fff_256x240.png) ]
[
Asset(v1\assets\fonts\glyphicons-halflings-regular.eot)
]
[
Asset(v1\assets\fonts\glyphicons-halflings-regular.woff)
]
[ Asset(v1\assets\fonts\glyphicons-regular.eot) ]
[ Asset(v1\assets\fonts\glyphicons-regular.woff) ]
[
Asset(v1\node_modules\leaflet\dist\images\layers.png)
]
[
Asset(v1\node_modules\leaflet\dist\images\marker-icon.png)
]
[ Asset(v1\css\images\ui-icons_ffffff_256x240.png) ]
[ Asset(v1\css\images\ui-icons_cc0000_256x240.png) ]

🎛 Configuration (.babelrc, package.json, cli command)

{
  "extends": ["@parcel/config-default"],
  "transformers": {
    "*.svelte": ["parcel-transformer-svelte"],
    "*.hbs": ["@andreyvolokitin/parcel-transformer-handlebars"]
  }
}

🌍 Your Environment

Software Version(s)
Parcel 2.0.0
Node v14.18.0
npm 6.14.15
Operating System Win 11
Activity icon
issue

louis77 issue comment louis77/tuner

louis77
louis77

Please how to start yours excellent radio player manually

I have built your wonderful radio player app. But how to start it manually please? Command tuner do not work. Which is The compiled executable binary name please?

louis77
louis77

It is com.github.louis77.tuner

Oct
13
1 month ago
push

louis77 push louis77/tuner

louis77
louis77
louis77
louis77

Make station list flexible (1-3 columns)

commit sha: 2247ba44dce9bb9a46e90dab7f0f3ddcae2e164d

push time in 1 month ago
Activity icon
issue

louis77 issue comment louis77/tuner

louis77
louis77

Play in background

Hi, Until eOS6, I used Melody (https://github.com/artemanufrij/playmymusic) for playing streams. Melody has not been updated for the new AppCenter packaging, so I went looking for an alternative - and found Tuner.

First of all, thank you! Tuner looks and works great.

I have a few requests/suggestions:

  • An option to display stations as a one list, instead of two parallel lists
  • An option to choose a pane to open on. I'd usually want to go directly to Starred by You when opening Tuner.
  • Not sure if this is possible, but showing the currently playing song (with station - so eg "Song - Station") in the Music Wingpanel plugin.
  • And really the biggest one for me - background play. Melody allowed me to close the app, and it would continue playing.

Thank you again!

louis77
louis77

Hey @dcowan-london, Background playback is implemented. As soon as elementary will publish the release you can update Tuner via AppCenter. Let me know if it works for you and what you think.

Activity icon
issue

louis77 issue louis77/tuner

louis77
louis77

Missing release tags in AppData

Hey there! I'd like to publish Tuner 1.4.4 in AppCenter but it looks like there is no release tag in appdata for this new release

Activity icon
issue

louis77 issue comment louis77/tuner

louis77
louis77

Missing release tags in AppData

Hey there! I'd like to publish Tuner 1.4.4 in AppCenter but it looks like there is no release tag in appdata for this new release

louis77
louis77

Hi @danrabbit Sorry, I was unresponsive for a while. Release 1.5.0 is out and I added release tags this time. Hopefully it works out.

Activity icon
created tag

louis77 in louis77/tuner create tag 1.5.0

createdAt 1 month ago
Activity icon
published release Background playback

louis77 in louis77/tuner create published release Background playback

createdAt 1 month ago
push

louis77 push louis77/tuner

louis77
louis77

Add release info to appdata

commit sha: 82549f01ae718cbe941e0f659dfb5e9867dc1f92

push time in 1 month ago
push

louis77 push louis77/tuner

louis77
louis77

Move Preferences in separate class

louis77
louis77

Replace theme switch with 3-mode dropdown

louis77
louis77

Implement background playback #67

louis77
louis77

Merge branch 'master' of github.com:louis77/tuner

commit sha: 7c3d151b7965a075811ad15b08e7833a564d0d5c

push time in 1 month ago
Oct
11
1 month ago
push

louis77 push louis77/tuner

louis77
louis77

Remove sudo and update pacstall URL

louis77
louis77

Merge pull request #70 from Henryws/master

Remove sudo and update pacstall URL

commit sha: 5c198c961c09645ed55e3911f67caab1fab5ef20

push time in 1 month ago
pull request

louis77 pull request louis77/tuner

louis77
louis77

Remove sudo and update pacstall URL

Oct
4
1 month ago
Activity icon
issue

louis77 issue comment flathub/com.github.louis77.tuner

louis77
louis77

updating elementary base image and runtime version

Runtime reached end of life, see raise issue:

https://github.com/flathub/com.github.louis77.tuner/issues/1

louis77
louis77

I found a similar issue here: https://github.com/phase1geo/Minder/issues/364

Seems to be a problem with Granite library and elementary 6. I also found a fix for that: https://github.com/phase1geo/Minder/commit/9a27fb76fdc8943b00b155d92032a76e8520cd2e

Activity icon
created branch

louis77 in louis77/tuner create branch flatpak-1

createdAt 1 month ago
Activity icon
issue

louis77 issue comment flathub/com.github.louis77.tuner

louis77
louis77

updating elementary base image and runtime version

Runtime reached end of life, see raise issue:

https://github.com/flathub/com.github.louis77.tuner/issues/1

louis77
louis77

I'm wondering where this error is coming from, Tuner doesn't contain a Settings.vala file. I'll try reproduce it with a fresh Debian 11 install.

Activity icon
issue

louis77 issue caprover/caprover

louis77
louis77

caprover CLI asks for branch twice

What is the problem?

Using the caprover CLI in PowerShell, it asks for the branch to be deployed twice:

Preparing deployment to CapRover...

? select the CapRover machine name you want to deploy to: cap01-pxl
Ensuring authentication...
? select the app name you want to deploy to: app-test
? git branch name to be deployed: (master) native-docker        
? git branch name to be deployed: native-docker
? note that uncommitted and gitignored files (if any) will not be pushed to server! Are you sure you want to deploy? Y
es

Steps to reproduce the problem:

Deploy an app using PowerShell (within VSCode).

caprover CLI version: 2.2.3

Oct
1
1 month ago
Activity icon
issue

louis77 issue comment Azure/azure-functions-powershell-worker

louis77
louis77

Local debugging in VS Code fails after app restart

Repro steps:

  1. Start a PowerShell Function app in VS Code by F5.
  2. Wait for the app to start. Invoke a function or do not invoke any function - does not seem to matter.
  3. Stop the app: hit the Disconnect button or push Ctrl-C in the terminal.
  4. Start the app again by F5. About 2-5 seconds after the app start, it stops and the following message appears in the terminal window: Debug-Runspace: You cannot debug the default host Runspace using this cmdlet. To debug the default Runspace use the normal debugging commands from the host.

Further attempts to start the app fail with the same error, until VS Code is restarted.

louis77
louis77

Adding my five cents to this issue. I experience the same problem with the most recent versions of VS Code and the Azure functions extension. Restarting the debugging session breaks it with an error message "There is no process with the given ID". I must wait for 3-5 seconds until I can successfully restart debugging with F5.

I just started with Azure Functions and this makes it cumbersome to develop.

Sep
30
1 month ago
Activity icon
issue

louis77 issue comment louis77/tuner

louis77
louis77

Web Search on song

It would be nice to have a search button right next to the displayed "performer - song" that is being played that would pop up a browser with a search of this so that you can get more info on what is playing.

louis77
louis77

What search engine would you prefer?

Sep
18
2 months ago
Previous