loveyunk

loveyunk

春天的道路依然充满泥泞!

Member Since 6 years ago

克莱登, Beijing, China

Experience Points
13
follower
Lessons Completed
51
follow
Lessons Completed
185
stars
Best Reply Awards
87
repos

31 contributions in the last year

Pinned
⚡ User dashboard example based on Vue2 and Element UI.
⚡ React pagination component
⚡ My personal eslint preferences
⚡ React Button Component
⚡ User dashboard example based on vue2 and tailwindcss.
Activity
Nov
18
2 weeks ago
Activity icon
issue

loveyunk issue comment umijs/fabric

loveyunk
loveyunk

2.8.0版本eslint异常

降到2.7.0版本后正常

loveyunk
loveyunk

他也是个规则合集 里面的规则和我们依赖的重复了

不知道你说的重复是指跟哪个重复了?

现在问题是你把大部分规则都移除了。就像 @maqinghao 上面提到的一些常用的规则都没有了,直接影响到使用者了,你觉得这样是没有问题的吗?

Activity icon
issue

loveyunk issue comment umijs/fabric

loveyunk
loveyunk

2.8.0版本eslint异常

降到2.7.0版本后正常

loveyunk
loveyunk

不知道你说的重复是指跟哪个重复了?

现在问题是你把大部分规则都移除了。就像 @maqinghao 上面提到的一些常用的规则都没有了,直接影响到使用者了,你觉得这样是没有问题的吗?

Nov
17
2 weeks ago
Activity icon
issue

loveyunk issue comment umijs/fabric

loveyunk
loveyunk

2.8.0版本eslint异常

降到2.7.0版本后正常

loveyunk
loveyunk

为了减少依赖。。。

有什么必要规则缺失了吗

Airbnb rules 全都没有了啊,这还不叫缺失吗?

Activity icon
issue

loveyunk issue comment umijs/fabric

loveyunk
loveyunk

2.8.0版本eslint异常

降到2.7.0版本后正常

loveyunk
loveyunk

为了减少依赖。。。

有什么必要规则缺失了吗

移除的所有规则都没有了啊,整个规则集全变了,还要怎么缺失?

Activity icon
issue

loveyunk issue comment umijs/fabric

loveyunk
loveyunk

2.8.0版本eslint异常

降到2.7.0版本后正常

loveyunk
loveyunk

好像是 v2.8.0 https://github.com/umijs/fabric/commit/4fc937ca52fcc47d6499f36fb5ac6fd46048e578 把包括 eslint-config-airbnb-base 在内的很多 ESLint 配置或插件移除了,导致很多基础 lint 规则失效了

不知道为什么这样? @chenshuai2144

Oct
24
1 month ago
Activity icon
issue

loveyunk issue comment streamich/react-use

loveyunk
loveyunk

Storybook deployment errors out

https://streamich.github.io/react-use/ has the following error:

image

Module build failed (from ./node_modules/ts-loader/index.js):
TypeError: loaderContext.getOptions is not a function
    at getLoaderOptions (/root/repo/node_modules/ts-loader/dist/index.js:91:41)
    at Object.loader (/root/repo/node_modules/ts-loader/dist/index.js:14:21)
Error: Module build failed (from ./node_modules/ts-loader/index.js):
TypeError: loaderContext.getOptions is not a function
    at getLoaderOptions (/root/repo/node_modules/ts-loader/dist/index.js:91:41)
    at Object.loader (/root/repo/node_modules/ts-loader/dist/index.js:14:21)
    at Object.756 (https://streamich.github.io/react-use/main.f03a0dc5.iframe.bundle.js:1:8384)
    at __webpack_require__ (https://streamich.github.io/react-use/runtime~main.c19c90be.iframe.bundle.js:1:1301)
    at webpackContext (https://streamich.github.io/react-use/main.f03a0dc5.iframe.bundle.js:1:7982)
    at https://streamich.github.io/react-use/main.f03a0dc5.iframe.bundle.js:1:880
    at Array.forEach (<anonymous>)
    at loadStories (https://streamich.github.io/react-use/main.f03a0dc5.iframe.bundle.js:1:845)
    at https://streamich.github.io/react-use/vendors~main.f06e85f2.iframe.bundle.js:2:376709
    at ConfigApi.configure (https://streamich.github.io/react-use/vendors~main.f06e85f2.iframe.bundle.js:2:310963)
    at Object.configure (https://streamich.github.io/react-use/vendors~main.f06e85f2.iframe.bundle.js:2:380450)
    at configure (https://streamich.github.io/react-use/vendors~main.f06e85f2.iframe.bundle.js:2:70090)
Oct
22
1 month ago
started
started time in 1 month ago