msimonc

msimonc

Member Since 9 years ago

Two Pi Code, Sydney

Experience Points
2
follower
Lessons Completed
5
follow
Lessons Completed
22
stars
Best Reply Awards
1
repos

41 contributions in the last year

Pinned
⚡ This is a command line utility program to upgrade all the packages in your `package.json` to the latest version (potentially upgrading packages across major versions).
Activity
Sep
15
2 months ago
Sep
11
2 months ago
Activity icon
issue

msimonc issue WTTJ/welcome-ui

msimonc
msimonc

error on build (next.js)

all packages updated to latest, (that's how I keep finding issues ;) "@welcome-ui/core": "^3.5.0",

error on build (next.js) ./node_modules/@welcome-ui/variant-icon/dist/variant-icon.es.js Attempted import error: 'Box' is not exported from '@xstyled/styled-components' (imported as 'Box').

Activity icon
issue

msimonc issue comment node-fetch/node-fetch

msimonc
msimonc

Problem with importing node-fetch v3.0.0 and node v16.5.0

Even though I import node fetch as instructed for v3.0.0: import fetch from 'node-fetch';

I get en error: Error: Must use import to load ES Module: ...\node_modules\node-fetch\src\index.js require() of ES modules is not supported.

after downgrading to node-fetch v2.6.1, works fine

msimonc
msimonc

For Node 12 TS I'm reading use: "target": "es2019" "module": "commonjs" Too soon. Back out the change guys. ESM rogue is right. My project is breaking because "we think everyone should..."

Sep
6
2 months ago
Sep
2
2 months ago
started
started time in 2 months ago