mtigdemir

mtigdemir

Member Since 8 years ago

London, United Kingdom

Experience Points
17
follower
Lessons Completed
32
follow
Lessons Completed
224
stars
Best Reply Awards
30
repos

40 contributions in the last year

Pinned
⚡ AVA Network API Client for PHP
⚡ Deployer Pipeline Container for PHP Applications
⚡ Github Search From CLI (Fun Project)
Activity
Nov
25
1 week ago
started
started time in 1 week ago
Nov
10
3 weeks ago
started
started time in 3 weeks ago
started
started time in 3 weeks ago
Nov
8
4 weeks ago
started
started time in 3 weeks ago
Nov
3
1 month ago
Sep
22
2 months ago
Activity icon
issue

mtigdemir issue comment creativetimofficial/ct-material-kit-pro-react

mtigdemir
mtigdemir

[Bug] impossible to use - latest nodejs lts installed, components not compatible with react 17.0.2

Version

xxx

Reproduction link

https://www.creative-tim.com/new-issue/material-kit-pro-react

Operating System

Windows

Device

Surface Pro, also tried on MSI

Browser & Version

NA

Steps to reproduce

npm install from fresh results in not installing at all. Github issue logged in March matches my experience. Tried fresh install of CRA and then installing modules manually in the hope of just copying the components but several of the dependences (react-animate-slider, react-datetime) are not compatible with react 17.0.2 I've installed Node LTS

What is expected?

a working product... following the instructions on your documentation to generate the starting point

What is actually happening?

unable to get it working as per comments above


Solution

Additional comments

While I appreciate some issues when trying to put the components into my project I did not expect not even being able to run the kits out of the box. Please advise how to get this working otherwise I'm afraid I will have to contest the charges through PayPal as the product is not operational.

mtigdemir
mtigdemir

I purchased the same kit yesterday and tried to build it, unfortunately I'm getting the below error. I also tried to remove/upgrade the relevant package however, other dependencies also failing.

npm ERR! While resolving: [email protected] npm ERR! Found: reac[email protected] npm ERR! node_modules/react npm ERR! [email protected]"17.0.2" from the root project npm ERR! npm ERR! Could not resolve dependency: npm ERR! peer [email protected]">= 15.4.1 < 17.0.0-0" from [email protected] npm ERR! node_modules/react-animate-on-scroll npm ERR! [email protected]"2.1.5" from the root project npm ERR!

I was using the free version before, I wanted to support the creative team but sorry to say this. Free version is more stable :(

Sep
13
2 months ago
started
started time in 2 months ago
Sep
6
3 months ago
started
started time in 2 months ago