Oct
22
1 day ago
Activity icon
fork

Light33-J forked elyra-ai/component-library

⚡ Experimental Notebook and Script components ready to be dropped in an Elyra pipeline
Light33-J Apache License 2.0 Updated
fork time in 1 day ago
Oct
21
2 days ago
Activity icon
issue

Light33-J issue comment elyra-ai/component-library

Light33-J
Light33-J

Currently only python 3.6 and 3.8 is supported, but the version of Python is 3.7

I got warning and errors: Currently only python 3.6 and 3.8 is supported, in case you need a different version please open an issue at https://github.com/elyra-ai/component-library/issues

The version of Python is 3.7, please help take a look at, thanks. ~/conda/envs/python/lib/python3.7/site-packages/IPython/core/interactiveshell.py in run_cell_magic(self, magic_name, line, cell)

Light33-J
Light33-J

You can also check your python version with this code, for all practical purposes !

from platform import python_version print(python_version())

I hope this can help !!

Activity icon
issue

Light33-J issue comment elyra-ai/component-library

Light33-J
Light33-J

Currently only python 3.6 and 3.8 is supported, but the version of Python is 3.7

I got warning and errors: Currently only python 3.6 and 3.8 is supported, in case you need a different version please open an issue at https://github.com/elyra-ai/component-library/issues

The version of Python is 3.7, please help take a look at, thanks. ~/conda/envs/python/lib/python3.7/site-packages/IPython/core/interactiveshell.py in run_cell_magic(self, magic_name, line, cell)

Light33-J
Light33-J

Hi asterix I am so sorry that you're facing issues with the code I provided. But I did use it well to go ahead with my Hands-on Lab.

Because now Version 36 and 37 don't exist in any lab environment, Here is my output for all practical purposes !

Capture

Oct
20
3 days ago
Activity icon
issue

asterix816 issue comment elyra-ai/component-library

asterix816
asterix816

Currently only python 3.6 and 3.8 is supported, but the version of Python is 3.7

I got warning and errors: Currently only python 3.6 and 3.8 is supported, in case you need a different version please open an issue at https://github.com/elyra-ai/component-library/issues

The version of Python is 3.7, please help take a look at, thanks. ~/conda/envs/python/lib/python3.7/site-packages/IPython/core/interactiveshell.py in run_cell_magic(self, magic_name, line, cell)

asterix816
asterix816

This code works. I try it well

%%bash export version=python --version |awk '{print $2}' |awk -F"." '{print $1$2}'

if [ $version != '36' ]; then pip install pyspark==2.4.8 wget==3.2 pyspark2pmml==0.5.1 elif [ $version != '38' ]; then pip install pyspark==3.1.2 wget==3.2 pyspark2pmml==0.5.1 else echo 'Currently only python 3.6 and 3.8 is supported, in case you need a different version please open an issue at https://github.com/elyra-ai/component-library/issues' exit -1 fi

No, it does not work. it gives the following error: File "/tmp/ipykernel_992/2811835967.py", line 12 export version=python --version |awk '{print $2}' |awk -F"." '{print $1$2}' ^ SyntaxError: invalid syntax

Activity icon
issue

asterix816 issue comment elyra-ai/component-library

asterix816
asterix816

Currently only python 3.6 and 3.8 is supported, but the version of Python is 3.7

I got warning and errors: Currently only python 3.6 and 3.8 is supported, in case you need a different version please open an issue at https://github.com/elyra-ai/component-library/issues

The version of Python is 3.7, please help take a look at, thanks. ~/conda/envs/python/lib/python3.7/site-packages/IPython/core/interactiveshell.py in run_cell_magic(self, magic_name, line, cell)

asterix816
asterix816

Hello. Having the same issue as stated above. I cannot complete the module and keep advancing. I have been checking here for a solution since a week ago. This is very frustrating.

Oct
18
5 days ago
Activity icon
issue

DavidSagrario issue comment elyra-ai/component-library

DavidSagrario
DavidSagrario

Currently only python 3.6 and 3.8 is supported, but the version of Python is 3.7

I got warning and errors: Currently only python 3.6 and 3.8 is supported, in case you need a different version please open an issue at https://github.com/elyra-ai/component-library/issues

The version of Python is 3.7, please help take a look at, thanks. ~/conda/envs/python/lib/python3.7/site-packages/IPython/core/interactiveshell.py in run_cell_magic(self, magic_name, line, cell)

DavidSagrario
DavidSagrario

Hello - the problem still persists therefore the module Data Engineering and Machine Learning using Spark cannot be finished. Please assist. Python version 3.7 should be 3.8 or 3.6

Activity icon
issue

jaiswalsanjeev issue elyra-ai/component-library

jaiswalsanjeev
jaiswalsanjeev

Issue with using python 3.9

Having issue with using Python 3.9 in the lab. Please advise on the fix Screenshot 2021-10-18 at 3 52 05 PM .

Activity icon
issue

silviaRM issue comment elyra-ai/component-library

silviaRM
silviaRM

Currently only python 3.6 and 3.8 is supported, but the version of Python is 3.7

I got warning and errors: Currently only python 3.6 and 3.8 is supported, in case you need a different version please open an issue at https://github.com/elyra-ai/component-library/issues

The version of Python is 3.7, please help take a look at, thanks. ~/conda/envs/python/lib/python3.7/site-packages/IPython/core/interactiveshell.py in run_cell_magic(self, magic_name, line, cell)

silviaRM
silviaRM

Hello - the problem still persists therefore the module Data Engineering and Machine Learning using Spark cannot be finished. Please assist.

Oct
17
6 days ago
Activity icon
fork

diocom forked elyra-ai/component-library

⚡ Experimental Notebook and Script components ready to be dropped in an Elyra pipeline
diocom Apache License 2.0 Updated
fork time in 6 days ago
Previous