CocoaPods could not find compatible versions for pod "boost"

4
closed
Rc85
Rc85
Posted 3 months ago

CocoaPods could not find compatible versions for pod "boost" #32395

Version

0.66.0

Build Target(s)

iOS 11.0

Developer Environment

react-native-reanimated 2.3.0-beta-2

Terminal pod install --repo-update

Issue and Reproduction Steps

Trying to update my pods but I am getting error.

Analyzing dependencies
Fetching podspec for `RCT-Folly` from `../node_modules/react-native/third-party-podspecs/RCT-Folly.podspec`
[!] CocoaPods could not find compatible versions for pod "boost":
  In Podfile:
    RCT-Folly (from `../node_modules/react-native/third-party-podspecs/RCT-Folly.podspec`) was resolved to 2021.06.28.00-v2, which depends on
      boost

    React-cxxreact (from `../node_modules/react-native/ReactCommon/cxxreact`) was resolved to 0.66.0, which depends on
      boost (= 1.76.0)

Specs satisfying the `boost (= 1.76.0), boost` dependency were found, but they required a higher minimum deployment target.
github-actions[bot]
github-actions[bot]
Created 3 months ago
:warning: Missing Environment Information
:information_source: Your issue may be missing information about your development environment. You can obtain the missing information by running react-native info in a console.
elinahovakimyan
elinahovakimyan
Created 3 months ago

@Rc85 I am facing this same issue, how were you able to fix this?

Rc85
Rc85
Created 3 months ago

@Rc85 I am facing this same issue, how were you able to fix this?

Did you add pod 'boost', :podspec => '../node_modules/react-native/third-party-podspecs/boost.podspec' to your Podfile?

elinahovakimyan
elinahovakimyan
Created 3 months ago

@Rc85 That worked, thanks!