Could not resolve "@babel/runtime/helpers/esm/extends"

1
open
fengzilong
fengzilong
Posted 1 month ago

Could not resolve "@babel/runtime/helpers/esm/extends" #642

Bug report 🐞

Version & Environment

  • Version of browser: latest chrome
  • Version of geist-ui/react: latest

Expected Behaviour

The behavior I expect is no error reported

Actual results (or Errors)

I got an error:

image

BTW I am using Vite

Some components depend on @babel/runtime, but when I bundle component without @babel/runtime installed( for example when I compile with esbuild or swc )

It's not kind for new users

fengzilong
fengzilong
Created 1 month ago

Install @babel/runtime can solve this problem

Maybe we shall add @babel/runtime in peerDependencies or don't use babel to bundle component