Jan
19
6 days ago
started
started time in 5 days ago
Jan
18
1 week ago
push

renovate[bot] push streamich/memfs

renovate[bot]
renovate[bot]

chore(deps): update semantic-release monorepo

renovate[bot]
renovate[bot]

chore(deps): update node.js to v16

commit sha: 632816acf4eb4a0bf771905a8a41136a22ca53ee

push time in 6 days ago
started
started time in 1 week ago
push

dependabot[bot] push streamich/memfs

dependabot[bot]
dependabot[bot]

chore(deps): bump hosted-git-info from 2.8.8 to 2.8.9

Bumps hosted-git-info from 2.8.8 to 2.8.9.


updated-dependencies:

  • dependency-name: hosted-git-info dependency-type: indirect ...

Signed-off-by: dependabot[bot] [email protected]

commit sha: 890e7676e352968dc52dc5ad08920f82aee51b4a

push time in 1 week ago
push

dependabot[bot] push streamich/memfs

dependabot[bot]
dependabot[bot]
dependabot[bot]
dependabot[bot]

feat: 🎸 add .rmSync(), .rm(), and .promises.rm() methods

dependabot[bot]
dependabot[bot]

feat: 🎸 add support for "recursive" and "force" flags in .rm()

dependabot[bot]
dependabot[bot]

test: 💍 add .promises.rm() tests

dependabot[bot]
dependabot[bot]

Merge pull request #754 from streamich/rm

add .rm(), .rmSync(), and .promises.rm() methods

dependabot[bot]
dependabot[bot]

chore(release): 3.3.0 [skip ci]

3.3.0 (2021-09-19)

Bug Fixes

  • 🐛 remove unused method (05b2a47)

Features

  • 🎸 add .rmSync(), .rm(), and .promises.rm() methods (2414fb6)
  • 🎸 add support for "recursive" and "force" flags in .rm() (7f6714c)
dependabot[bot]
dependabot[bot]

chore(deps): update dependency jest to v27.2.1

dependabot[bot]
dependabot[bot]
dependabot[bot]
dependabot[bot]

chore(deps): update dependency @types/jest to v27.0.2

dependabot[bot]
dependabot[bot]

chore(deps): update dependency @semantic-release/changelog to v6

dependabot[bot]
dependabot[bot]

chore(deps): update dependency jest to v27.2.2

dependabot[bot]
dependabot[bot]

chore(deps): update dependency jest to v27.2.3

dependabot[bot]
dependabot[bot]

chore(deps): update dependency jest to v27.2.4

dependabot[bot]
dependabot[bot]

chore(deps): update dependency jest to v27.2.5

dependabot[bot]
dependabot[bot]

chore(deps): update dependency ts-node to v10.3.0

dependabot[bot]
dependabot[bot]

chore(deps): update dependency typescript to v4.4.4

dependabot[bot]
dependabot[bot]

chore(deps): update dependency ts-jest to v27.0.6

dependabot[bot]
dependabot[bot]

chore(deps): update dependency ts-node to v10.4.0

dependabot[bot]
dependabot[bot]

chore(deps): update dependency @semantic-release/npm to v8.0.2

dependabot[bot]
dependabot[bot]

chore(deps): update dependency husky to v7.0.4

commit sha: c615a783f6c76ddc9509e1d1f25405d20fa2a023

push time in 1 week ago
push

renovate[bot] push streamich/memfs

renovate[bot]
renovate[bot]

chore(deps): update semantic-release monorepo

commit sha: 138eb22b63267539ac4bec849be87318abf2606c

push time in 1 week ago
pull request

renovate[bot] pull request streamich/memfs

renovate[bot]
renovate[bot]

chore(deps): update semantic-release monorepo (major)

WhiteSource Renovate

This PR contains the following updates:

Package Change Age Adoption Passing Confidence
@semantic-release/npm 8.0.3 -> 9.0.0 age adoption passing confidence
semantic-release 18.0.1 -> 19.0.2 age adoption passing confidence

Release Notes

semantic-release/npm

v9.0.0

Compare Source

Bug Fixes
  • add preferLocal option to allow execa to use local npm version (#8203;445) (002439e)
  • updated the peer requirement for semantic-release to the new stable version (575a5a4)
  • updated the peer requirement on semantic-release to a version matching the engines definition of this package (2d1f5f2)
  • upgrade npm dependency to v8 (a12d6e5)
BREAKING CHANGES
  • the minimum required peer of semantic-release has been raised to match the engines.node requirements of this package
  • npm v8 dropped support for node v15, so it is no longer supported in this plugin. this should be low impact since node v15 is already EOL

Co-authored-by: Matt Travi [email protected]

semantic-release/semantic-release

v19.0.2

Compare Source

Bug Fixes
  • npm-plugin: upgraded to the stable version (0eca144)

v19.0.1

Compare Source

Bug Fixes
  • npm-plugin: upgraded to the latest beta version (8097afb)

v19.0.0

Compare Source

Bug Fixes
  • npm-plugin: upgraded to the beta, which upgrades npm to v8 (f634b8c)
  • upgrade marked to resolve ReDos vulnerability (#8203;2330) (d9e5bc0)
BREAKING CHANGES
  • npm-plugin: @semantic-release/npm has also dropped support for node v15
  • node v15 has been removed from our defined supported versions of node. this was done to upgrade to compatible versions of marked and marked-terminal that resolved the ReDoS vulnerability. removal of support of this node version should be low since it was not an LTS version and has been EOL for several months already.

Configuration

📅 Schedule: At any time (no schedule defined).

🚦 Automerge: Enabled.

Rebasing: Whenever PR becomes conflicted, or you tick the rebase/retry checkbox.

👻 Immortal: This PR will be recreated if closed unmerged. Get config help if that's undesired.


  • If you want to rebase/retry this PR, click this checkbox.

This PR has been generated by WhiteSource Renovate. View repository job log here.

Activity icon
delete

renovate[bot] in streamich/memfs delete branch renovate/major-semantic-release-monorepo

deleted time in 1 week ago
pull request

renovate[bot] pull request streamich/memfs

renovate[bot]
renovate[bot]

chore(deps): update semantic-release monorepo (major)

WhiteSource Renovate

This PR contains the following updates:

Package Change Age Adoption Passing Confidence
@semantic-release/npm 8.0.3 -> 9.0.0 age adoption passing confidence
semantic-release 18.0.1 -> 19.0.2 age adoption passing confidence

Release Notes

semantic-release/npm

v9.0.0

Compare Source

Bug Fixes
  • add preferLocal option to allow execa to use local npm version (#8203;445) (002439e)
  • updated the peer requirement for semantic-release to the new stable version (575a5a4)
  • updated the peer requirement on semantic-release to a version matching the engines definition of this package (2d1f5f2)
  • upgrade npm dependency to v8 (a12d6e5)
BREAKING CHANGES
  • the minimum required peer of semantic-release has been raised to match the engines.node requirements of this package
  • npm v8 dropped support for node v15, so it is no longer supported in this plugin. this should be low impact since node v15 is already EOL

Co-authored-by: Matt Travi [email protected]

semantic-release/semantic-release

v19.0.2

Compare Source

Bug Fixes
  • npm-plugin: upgraded to the stable version (0eca144)

v19.0.1

Compare Source

Bug Fixes
  • npm-plugin: upgraded to the latest beta version (8097afb)

v19.0.0

Compare Source

Bug Fixes
  • npm-plugin: upgraded to the beta, which upgrades npm to v8 (f634b8c)
  • upgrade marked to resolve ReDos vulnerability (#8203;2330) (d9e5bc0)
BREAKING CHANGES
  • npm-plugin: @semantic-release/npm has also dropped support for node v15
  • node v15 has been removed from our defined supported versions of node. this was done to upgrade to compatible versions of marked and marked-terminal that resolved the ReDoS vulnerability. removal of support of this node version should be low since it was not an LTS version and has been EOL for several months already.

Configuration

📅 Schedule: At any time (no schedule defined).

🚦 Automerge: Enabled.

Rebasing: Whenever PR becomes conflicted, or you tick the rebase/retry checkbox.

👻 Immortal: This PR will be recreated if closed unmerged. Get config help if that's undesired.


  • If you want to rebase/retry this PR, click this checkbox.

This PR has been generated by WhiteSource Renovate. View repository job log here.

Activity icon
created branch

renovate[bot] in streamich/memfs create branch renovate/major-semantic-release-monorepo

createdAt 1 week ago